summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/riece/riece-3.1.2.ebuild')
-rw-r--r--app-emacs/riece/riece-3.1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-3.1.2.ebuild b/app-emacs/riece/riece-3.1.2.ebuild
new file mode 100644
index 000000000000..af99ffa00d72
--- /dev/null
+++ b/app-emacs/riece/riece-3.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-3.1.2.ebuild,v 1.1 2007/05/16 14:35:02 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Riece is a redesign of Liece IRC client"
+HOMEPAGE="http://www.nongnu.org/riece/"
+SRC_URI="http://savannah.nongnu.org/download/riece/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~ppc64 ~amd64"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+
+src_compile() {
+ econf --with-lispdir="${SITELISP}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ einstall lispdir="${D}/${SITELISP}" || die "einstall failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ dodoc AUTHORS NEWS README doc/HACKING lisp/ChangeLog* || die "dodoc failed"
+}