summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/spacenavd/files')
-rw-r--r--app-misc/spacenavd/files/spacenavd-0.5-custom-flags.patch67
-rw-r--r--app-misc/spacenavd/files/spacenavd-0.5-destdir.patch16
-rw-r--r--app-misc/spacenavd/files/spnavd27
3 files changed, 110 insertions, 0 deletions
diff --git a/app-misc/spacenavd/files/spacenavd-0.5-custom-flags.patch b/app-misc/spacenavd/files/spacenavd-0.5-custom-flags.patch
new file mode 100644
index 000000000000..3b834a43952d
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd-0.5-custom-flags.patch
@@ -0,0 +1,67 @@
+diff -Npur spacenavd-0.5.orig/Makefile.in spacenavd-0.5/Makefile.in
+--- spacenavd-0.5.orig/Makefile.in 2012-01-31 22:22:20.460368687 +0100
++++ spacenavd-0.5/Makefile.in 2012-01-31 22:23:18.170367675 +0100
+@@ -6,8 +6,8 @@ ctl = spnavd_ctl
+
+ CC = gcc
+ INSTALL = install
+-CFLAGS = -pedantic -Wall $(dbg) $(opt) -fno-strict-aliasing -I$(srcdir)/src
+-LDFLAGS = $(xlib)
++CFLAGS = $(opt) -fno-strict-aliasing -I$(srcdir)/src
++LDFLAGS = $(ldopt) $(xlib)
+
+ $(bin): $(obj)
+ $(CC) -o $@ $(obj) $(LDFLAGS)
+diff -Npur spacenavd-0.5.orig/configure spacenavd-0.5/configure
+--- spacenavd-0.5.orig/configure 2012-01-31 22:22:20.460368687 +0100
++++ spacenavd-0.5/configure 2012-01-31 22:22:49.257368187 +0100
+@@ -28,6 +28,7 @@ test_kver() {
+
+ PREFIX=/usr/local
+ OPT=yes
++LDOPT=yes
+ DBG=yes
+ X11=yes
+ HOTPLUG=yes
+@@ -70,6 +71,11 @@ for arg; do
+ --disable-opt)
+ OPT=no;;
+
++ --enable-ldopt)
++ LDOPT=yes;;
++ --disable-ldopt)
++ LDOPT=no;;
++
+ --enable-debug)
+ DBG=yes;;
+ --disable-debug)
+@@ -95,6 +101,8 @@ for arg; do
+ echo ' --disable-hotplug: disable hotplug, fallback to polling for the device'
+ echo ' --enable-opt: enable speed optimizations (default)'
+ echo ' --disable-opt: disable speed optimizations'
++ echo ' --enable-ldopt: enable link optimizations (default)'
++ echo ' --disable-ldopt: disable link optimizations'
+ echo ' --enable-debug: include debugging symbols (default)'
+ echo ' --disable-debug: do not include debugging symbols'
+ echo 'all invalid options are silently ignored'
+@@ -105,6 +113,7 @@ done
+
+ echo " prefix: $PREFIX"
+ echo " optimize for speed: $OPT"
++echo " optimize link: $LDOPT"
+ echo " include debugging symbols: $DBG"
+ echo " x11 communication method: $X11"
+ echo " use hotplug: $HOTPLUG"
+@@ -128,7 +137,11 @@ if [ "$DBG" = 'yes' ]; then
+ fi
+
+ if [ "$OPT" = 'yes' ]; then
+- echo 'opt = -O3' >>Makefile
++ echo "opt = ${CFLAGS:--O3}" >>Makefile
++fi
++
++if [ "$LDOPT" = 'yes' ]; then
++ echo "ldopt = ${LDFLAGS}" >>Makefile
+ fi
+
+ if [ "$X11" = 'yes' ]; then
diff --git a/app-misc/spacenavd/files/spacenavd-0.5-destdir.patch b/app-misc/spacenavd/files/spacenavd-0.5-destdir.patch
new file mode 100644
index 000000000000..5b2372242e14
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd-0.5-destdir.patch
@@ -0,0 +1,16 @@
+diff -Npur spacenavd-0.5.orig/Makefile.in spacenavd-0.5/Makefile.in
+--- spacenavd-0.5.orig/Makefile.in 2011-11-16 21:43:53.210859753 +0100
++++ spacenavd-0.5/Makefile.in 2011-11-16 21:45:36.386857932 +0100
+@@ -24,9 +24,9 @@ clean:
+
+ .PHONY: install
+ install: $(bin)
+- $(INSTALL) -d $(PREFIX)/bin
+- $(INSTALL) -m 755 $(bin) $(PREFIX)/bin/$(bin)
+- $(INSTALL) -m 755 $(srcdir)/$(ctl) $(PREFIX)/bin/$(ctl)
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -m 755 $(bin) $(DESTDIR)$(PREFIX)/bin/$(bin)
++ $(INSTALL) -m 755 $(srcdir)/$(ctl) $(DESTDIR)$(PREFIX)/bin/$(ctl)
+ cd $(srcdir) && ./setup_init --no-install
+
+ # [ -d /etc/hal/fdi/policy ] && \
diff --git a/app-misc/spacenavd/files/spnavd b/app-misc/spacenavd/files/spnavd
new file mode 100644
index 000000000000..383a2adc390f
--- /dev/null
+++ b/app-misc/spacenavd/files/spnavd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need localmount
+ after bootmisc
+}
+
+start() {
+ ebegin "Starting Spacenav system daemon"
+
+ start-stop-daemon --start --pidfile /var/run/spnavd.pid --exec /usr/bin/spacenavd
+ eend $?
+}
+
+stop() {
+ local retval
+
+ ebegin "Stopping Spacenav system daemon"
+
+ start-stop-daemon --stop --pidfile /var/run/spnavd.pid
+ retval=$?
+
+ eend ${retval}
+ return ${retval}
+}