summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/tpp/tpp-1.3.1-r1.ebuild')
-rw-r--r--app-office/tpp/tpp-1.3.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-office/tpp/tpp-1.3.1-r1.ebuild b/app-office/tpp/tpp-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..43d9b1f0b99b
--- /dev/null
+++ b/app-office/tpp/tpp-1.3.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/tpp-1.3.1-r1.ebuild,v 1.1 2010/07/15 05:28:01 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit eutils ruby-ng
+
+DESCRIPTION="An ncurses-based presentation tool."
+HOMEPAGE="http://synflood.at/tpp.html"
+SRC_URI="http://synflood.at/tpp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="figlet"
+
+RDEPEND="${RDEPEND} figlet? ( app-misc/figlet )"
+
+ruby_add_rdepend "dev-ruby/ncurses-ruby"
+
+RUBY_PATCHES=( "${FILESDIR}/${P}-Makefile.patch" )
+
+each_ruby_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}