summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/libnova/libnova-0.7.0.ebuild')
-rw-r--r--app-sci/libnova/libnova-0.7.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-sci/libnova/libnova-0.7.0.ebuild b/app-sci/libnova/libnova-0.7.0.ebuild
new file mode 100644
index 000000000000..519711b9a9f0
--- /dev/null
+++ b/app-sci/libnova/libnova-0.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/libnova/libnova-0.7.0.ebuild,v 1.1 2003/05/21 07:08:35 mkennedy Exp $
+
+DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
+HOMEPAGE="http://libnova.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libnova/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-doc/doxygen"
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ make || die
+ cd doc && make doc || die
+}
+
+src_install() {
+ dodir /usr/share/aclocal
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ LIBNOVA_MACRO_DIR=${D}/usr/share/aclocal \
+ install || die
+ dohtml doc/html/*
+ doman doc/man/*/*
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}