summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgmecab/pgmecab-1.1-r1.ebuild')
-rw-r--r--dev-db/pgmecab/pgmecab-1.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/pgmecab/pgmecab-1.1-r1.ebuild b/dev-db/pgmecab/pgmecab-1.1-r1.ebuild
new file mode 100644
index 000000000000..1d7f215e5eca
--- /dev/null
+++ b/dev-db/pgmecab/pgmecab-1.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgmecab/pgmecab-1.1-r1.ebuild,v 1.1 2008/08/14 23:54:50 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="PostgreSQL function to Wakachigaki for Japanese words"
+HOMEPAGE="http://www.emaki.minidns.net/Programming/postgres/index.html"
+SRC_URI="http://www.emaki.minidns.net/Programming/postgres/${P}.tar.bz2"
+
+DEPEND="app-text/mecab
+ >=virtual/postgresql-server-7.4"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack () {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake USE_PGXS=1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install || die
+}