summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite/sqlite-2.8.6.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-2.8.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-db/sqlite/sqlite-2.8.6.ebuild b/dev-db/sqlite/sqlite-2.8.6.ebuild
new file mode 100644
index 000000000000..b4469f448fb6
--- /dev/null
+++ b/dev-db/sqlite/sqlite-2.8.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.6.ebuild,v 1.1 2003/09/30 20:11:05 nakano Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/sqlite
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.hwaci.com/sw/sqlite/${P}.tar.gz"
+HOMEPAGE="http://www.hwaci.com/sw/sqlite/"
+DEPEND="virtual/glibc
+ dev-lang/tcl"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~arm ~hppa"
+
+src_compile() {
+ local myconf
+ myconf="--enable-incore-db --enable-tempdb-in-ram"
+ myconf="${myconf} `use_with nls utf8`"
+ econf ${myconf} || die
+ emake all doc || die
+}
+
+src_install () {
+ dodir /usr/{bin,include,lib}
+
+ einstall || die
+
+ dobin lemon
+ dodoc README VERSION
+ doman sqlite.1
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
+}
+