summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/xmysqladmin/xmysqladmin-1.0.ebuild')
-rw-r--r--dev-db/xmysqladmin/xmysqladmin-1.0.ebuild33
1 files changed, 20 insertions, 13 deletions
diff --git a/dev-db/xmysqladmin/xmysqladmin-1.0.ebuild b/dev-db/xmysqladmin/xmysqladmin-1.0.ebuild
index 3b260fcc2418..0e4445a5c412 100644
--- a/dev-db/xmysqladmin/xmysqladmin-1.0.ebuild
+++ b/dev-db/xmysqladmin/xmysqladmin-1.0.ebuild
@@ -1,22 +1,26 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Ben Lutgens <lamer@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xmysqladmin/xmysqladmin-1.0.ebuild,v 1.1 2001/09/11 18:50:23 lamer Exp $
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xmysqladmin/xmysqladmin-1.0.ebuild,v 1.1.1.1 2005/11/30 10:11:39 chriswhite Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="xforms based front end to mysql"
SRC_URI="ftp://ftp.mysql.com/Contrib/${P}.tar.gz"
HOMEPAGE="http://www.mysql.org"
-DEPEND="virtual/x11
- >=x11-libs/xforms-089"
-#RDEPEND=""
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 sparc ~amd64"
+IUSE=""
+
+DEPEND="virtual/x11
+ x11-libs/xforms
+ dev-db/mysql"
src_unpack() {
unpack ${A}
cd ${S}
sed -e 's:^INSTALLPATH.*:INSTALLPATH = /usr/bin:g' -e \
's:^PIXMAPPATH.*:PIXMAPPATH = /usr/share/pixmaps:g' -e \
+ 's:-I/usr/X11R6/include:-I/usr/X11R6/include/X11:g' -e \
's:^MYSQLINC.*:MYSQLINC = -I/usr/include/mysql:g' -e \
's:^MYSQLDBDIR.*:MYSQLDBDIR = -DMYSQLDBDIR=\\\"/var/mysql\\\":g' -e \
's:^MYSQLLOAD.*:MYSQLLOAD = \-Wl\,\-R/usr/lib/mysql \-L/usr/lib/mysql \-lmysqlclient:g' -e \
@@ -24,15 +28,18 @@ src_unpack() {
}
src_compile() {
-
+
make -f Makefile.gentoo || die
}
src_install () {
-
+
dodir /usr/bin
dodir /usr/share/pixmaps
- try make INSTALLPATH=${D}/usr/bin PIXMAPPATH=${D}/usr/share/pixmaps install
- dodoc README INSTALL CHANGES ANNOUNCE TODO
-}
+ make \
+ INSTALLPATH=${D}/usr/bin \
+ PIXMAPPATH=${D}/usr/share/pixmaps \
+ install || die
+ dodoc README INSTALL CHANGES ANNOUNCE TODO
+}