summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/nant/nant-0.90.ebuild')
-rw-r--r--dev-dotnet/nant/nant-0.90.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-dotnet/nant/nant-0.90.ebuild b/dev-dotnet/nant/nant-0.90.ebuild
new file mode 100644
index 000000000000..854ca68c40c9
--- /dev/null
+++ b/dev-dotnet/nant/nant-0.90.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/nant-0.90.ebuild,v 1.1 2010/11/26 11:23:56 pacho Exp $
+
+EAPI="3"
+
+inherit mono multilib eutils
+
+DESCRIPTION=".NET build tool"
+HOMEPAGE="http://nant.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nant/${P/_/-}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# This build is not parallel build friendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install || die "install failed"
+
+ # Fix ${ED} showing up in the nant wrapper script, as well as silencing
+ # warnings related to the log4net library
+ sed -i \
+ -e "s:${ED}::" \
+ -e "2iexport MONO_SILENT_WARNING=1" \
+ -e "s:${ED}::" \
+ "${ED}"/usr/bin/nant || die "Sed nant failed"
+
+ dodoc README.txt || die
+}