summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/dbunit/dbunit-2.4.1.ebuild')
-rw-r--r--dev-java/dbunit/dbunit-2.4.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/dbunit/dbunit-2.4.1.ebuild b/dev-java/dbunit/dbunit-2.4.1.ebuild
new file mode 100644
index 000000000000..45b74eb6bab4
--- /dev/null
+++ b/dev-java/dbunit/dbunit-2.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dbunit/dbunit-2.4.1.ebuild,v 1.1 2009/01/12 19:43:10 betelgeuse Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="DbUnit is a JUnit extension targeted for database-driven projects"
+HOMEPAGE="http://dbunit.sourceforge.net/"
+SRC_URI="http://internap.dl.sourceforge.net/sourceforge/dbunit/${P}-sources.jar"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+COMMON_DEP="dev-java/slf4j-api
+ dev-java/poi:3.2
+ dev-java/commons-collections:0
+ dev-java/ant-core
+ dev-java/junit"
+
+RDEPEND=">=virtual/jre-1.4
+ dev-java/slf4j-nop
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+#instead of making a folder
+S="${WORKDIR}"
+
+src_prepare(){
+ #Upstream no longer provides a build file.
+ cp -v "${FILESDIR}"/build-2.4.xml "${S}/build.xml" || die
+}
+
+EANT_GENTOO_CLASSPATH="poi-3.2,junit,slf4j-api,commons-collections,ant-core"
+
+src_install() {
+ #slf4j needed for runtime
+ java-pkg_register-optional-dependency slf4j-nop
+ java-pkg_register-optional-dependency slf4j-log4j12
+ java-pkg_dojar "${S}"/dist/"${PN}.jar"
+ use doc && java-pkg_dojavadoc build/javadoc
+ use source && java-pkg_dosrc org
+}
+