summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild')
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild
index cdcb4d1ce3b7..2a3bc2f34127 100644
--- a/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild,v 1.7 2007/02/18 10:20:29 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild,v 1.8 2007/05/01 08:23:16 fordfrog Exp $
inherit java-pkg-2 java-ant-2
@@ -53,10 +53,6 @@ src_unpack() {
# patch to make junit test work + correction for doc target
cd ${S}
epatch ${FILESDIR}/${P}-build.xml.patch
-
- mkdir lib
- cd lib
- java-pkg_jar-from junit
}
src_compile() {
@@ -76,7 +72,7 @@ src_install() {
if use_doc; then
java-pkg_dojavadoc build/publicapi
- java-pkg_dohtml build/doc/pgjdbc.html
+ dohtml build/doc/pgjdbc.html
fi
use source && java-pkg_dosrc org
@@ -92,5 +88,8 @@ src_test() {
einfo "You can find a general info on how to perform these steps at"
einfo "http://gentoo-wiki.com/HOWTO_Configure_Postgresql"
+ mkdir lib
+ java-pkg_jar-from --into lib junit
+
ANT_TASKS="ant-junit" eant test
}