summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/files/python-2.4.1-readline.patch')
-rw-r--r--dev-lang/python/files/python-2.4.1-readline.patch294
1 files changed, 0 insertions, 294 deletions
diff --git a/dev-lang/python/files/python-2.4.1-readline.patch b/dev-lang/python/files/python-2.4.1-readline.patch
deleted file mode 100644
index 2db5a82b4efa..000000000000
--- a/dev-lang/python/files/python-2.4.1-readline.patch
+++ /dev/null
@@ -1,294 +0,0 @@
-diff -u Python-2.4.1/configure Python-2.4.1.new/configure
---- Python-2.4.1/configure 2005-03-29 00:23:02.000000000 +0100
-+++ Python-2.4.1.new/configure 2005-04-26 14:14:49.373258580 +0100
-@@ -1,5 +1,5 @@
- #! /bin/sh
--# From configure.in Revision: 1.475.2.7 .
-+# From configure.in Revision: 1.475.2.8 .
- # Guess values for system-dependent variables and create Makefiles.
- # Generated by GNU Autoconf 2.59 for python 2.4.
- #
-@@ -19306,6 +19306,217 @@
-
- fi
-
-+# what library does readline need to be linked with
-+READLINE_SHARED_LIBADD=""
-+echo "$as_me:$LINENO: checking for tgetent in -lncurses" >&5
-+echo $ECHO_N "checking for tgetent in -lncurses... $ECHO_C" >&6
-+if test "${ac_cv_lib_ncurses_tgetent+set}" = set; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ ac_check_lib_save_LIBS=$LIBS
-+LIBS="-lncurses $LIBS"
-+cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+
-+/* Override any gcc2 internal prototype to avoid an error. */
-+#ifdef __cplusplus
-+extern "C"
-+#endif
-+/* We use char because int might match the return type of a gcc2
-+ builtin and then its argument prototype would still apply. */
-+char tgetent ();
-+int
-+main ()
-+{
-+tgetent ();
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ ac_cv_lib_ncurses_tgetent=yes
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+ac_cv_lib_ncurses_tgetent=no
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+LIBS=$ac_check_lib_save_LIBS
-+fi
-+echo "$as_me:$LINENO: result: $ac_cv_lib_ncurses_tgetent" >&5
-+echo "${ECHO_T}$ac_cv_lib_ncurses_tgetent" >&6
-+if test $ac_cv_lib_ncurses_tgetent = yes; then
-+ READLINE_SHARED_LIBADD="-lncurses"
-+else
-+ echo "$as_me:$LINENO: checking for tgetent in -lcurses" >&5
-+echo $ECHO_N "checking for tgetent in -lcurses... $ECHO_C" >&6
-+if test "${ac_cv_lib_curses_tgetent+set}" = set; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ ac_check_lib_save_LIBS=$LIBS
-+LIBS="-lcurses $LIBS"
-+cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+
-+/* Override any gcc2 internal prototype to avoid an error. */
-+#ifdef __cplusplus
-+extern "C"
-+#endif
-+/* We use char because int might match the return type of a gcc2
-+ builtin and then its argument prototype would still apply. */
-+char tgetent ();
-+int
-+main ()
-+{
-+tgetent ();
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ ac_cv_lib_curses_tgetent=yes
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+ac_cv_lib_curses_tgetent=no
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+LIBS=$ac_check_lib_save_LIBS
-+fi
-+echo "$as_me:$LINENO: result: $ac_cv_lib_curses_tgetent" >&5
-+echo "${ECHO_T}$ac_cv_lib_curses_tgetent" >&6
-+if test $ac_cv_lib_curses_tgetent = yes; then
-+ READLINE_SHARED_LIBADD="-lcurses"
-+else
-+ echo "$as_me:$LINENO: checking for tgetent in -ltermcap" >&5
-+echo $ECHO_N "checking for tgetent in -ltermcap... $ECHO_C" >&6
-+if test "${ac_cv_lib_termcap_tgetent+set}" = set; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ ac_check_lib_save_LIBS=$LIBS
-+LIBS="-ltermcap $LIBS"
-+cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+
-+/* Override any gcc2 internal prototype to avoid an error. */
-+#ifdef __cplusplus
-+extern "C"
-+#endif
-+/* We use char because int might match the return type of a gcc2
-+ builtin and then its argument prototype would still apply. */
-+char tgetent ();
-+int
-+main ()
-+{
-+tgetent ();
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-+ (eval $ac_link) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest$ac_exeext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ ac_cv_lib_termcap_tgetent=yes
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+ac_cv_lib_termcap_tgetent=no
-+fi
-+rm -f conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+LIBS=$ac_check_lib_save_LIBS
-+fi
-+echo "$as_me:$LINENO: result: $ac_cv_lib_termcap_tgetent" >&5
-+echo "${ECHO_T}$ac_cv_lib_termcap_tgetent" >&6
-+if test $ac_cv_lib_termcap_tgetent = yes; then
-+ READLINE_SHARED_LIBADD="-ltermcap"
-+fi
-+
-+
-+fi
-+
-+
-+fi
-+
-+
- # check for readline 2.1
- echo "$as_me:$LINENO: checking for rl_callback_handler_install in -lreadline" >&5
- echo $ECHO_N "checking for rl_callback_handler_install in -lreadline... $ECHO_C" >&6
-@@ -19313,7 +19524,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lreadline -ltermcap $LIBS"
-+LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -19445,7 +19656,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lreadline -ltermcap $LIBS"
-+LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -19519,7 +19730,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lreadline -ltermcap $LIBS"
-+LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-diff -u Python-2.4.1/configure.in Python-2.4.1.new/configure.in
---- Python-2.4.1/configure.in 2005-03-29 00:23:34.000000000 +0100
-+++ Python-2.4.1.new/configure.in 2005-04-26 14:01:03.721206572 +0100
-@@ -2846,10 +2846,18 @@
- [Define this if you have flockfile(), getc_unlocked(), and funlockfile()])
- fi
-
-+# what library does readline need to be linked with
-+READLINE_SHARED_LIBADD=""
-+AC_CHECK_LIB(ncurses, tgetent, [READLINE_SHARED_LIBADD="-lncurses"],
-+ AC_CHECK_LIB(curses, tgetent, [READLINE_SHARED_LIBADD="-lcurses"],
-+ AC_CHECK_LIB(termcap, tgetent, [READLINE_SHARED_LIBADD="-ltermcap"])
-+ )
-+ )
-+
- # check for readline 2.1
- AC_CHECK_LIB(readline, rl_callback_handler_install,
- AC_DEFINE(HAVE_RL_CALLBACK, 1,
-- [Define if you have readline 2.1]), , -ltermcap)
-+ [Define if you have readline 2.1]), , $READLINE_SHARED_LIBADD)
-
- # check for readline 2.2
- AC_TRY_CPP([#include <readline/readline.h>],
-@@ -2865,12 +2873,12 @@
- # check for readline 4.0
- AC_CHECK_LIB(readline, rl_pre_input_hook,
- AC_DEFINE(HAVE_RL_PRE_INPUT_HOOK, 1,
-- [Define if you have readline 4.0]), , -ltermcap)
-+ [Define if you have readline 4.0]), , $READLINE_SHARED_LIBADD)
-
- # check for readline 4.2
- AC_CHECK_LIB(readline, rl_completion_matches,
- AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1,
-- [Define if you have readline 4.2]), , -ltermcap)
-+ [Define if you have readline 4.2]), , $READLINE_SHARED_LIBADD)
-
- # also in readline 4.2
- AC_TRY_CPP([#include <readline/readline.h>],
-