summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.5.4-r3.ebuild')
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild37
1 files changed, 26 insertions, 11 deletions
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index 407e8acab929..599b795691fe 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.15 2009/08/30 21:34:13 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.16 2009/09/22 13:39:28 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -11,7 +11,7 @@ EAPI="1"
inherit autotools eutils flag-o-matic libtool multilib pax-utils python toolchain-funcs versionator
-# We need this so that we don't depends on python.eclass
+# We need this so that we don't depend on python.eclass.
PYVER_MAJOR=$(get_major_version)
PYVER_MINOR=$(get_version_component_range 2)
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
@@ -29,7 +29,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.5"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="berkdb build doc elibc_uclibc examples gdbm ipv6 ncurses readline sqlite ssl +threads tk ucs2 wininst +xml"
+IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 ncurses readline sqlite ssl +threads tk ucs2 wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes}
# do not conflict with the ones in python proper. - liquidx
@@ -37,22 +37,37 @@ IUSE="berkdb build doc elibc_uclibc examples gdbm ipv6 ncurses readline sqlite s
DEPEND=">=app-admin/eselect-python-20080925
>=sys-libs/zlib-1.1.3
!build? (
- sqlite? ( >=dev-db/sqlite-3 )
- tk? ( >=dev-lang/tk-8.0 )
- ncurses? ( >=sys-libs/ncurses-5.2
- readline? ( >=sys-libs/readline-4.1 ) )
- berkdb? ( || ( sys-libs/db:4.5 sys-libs/db:4.4 sys-libs/db:4.3
- sys-libs/db:4.2 ) )
+ berkdb? ( || (
+ sys-libs/db:4.5
+ sys-libs/db:4.4
+ sys-libs/db:4.3
+ sys-libs/db:4.2
+ ) )
+ doc? ( dev-python/python-docs:${SLOT} )
gdbm? ( sys-libs/gdbm )
+ ncurses? (
+ >=sys-libs/ncurses-5.2
+ readline? ( >=sys-libs/readline-4.1 )
+ )
+ sqlite? ( >=dev-db/sqlite-3 )
ssl? ( dev-libs/openssl )
- doc? ( dev-python/python-docs:${SLOT} )
+ tk? ( >=dev-lang/tk-8.0 )
xml? ( >=dev-libs/expat-2 )
- )"
+ )"
RDEPEND="${DEPEND}"
PDEPEND="${DEPEND} app-admin/python-updater"
PROVIDE="virtual/python"
+pkg_setup() {
+ if use berkdb; then
+ ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
+ ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
+ ewarn "module provided by dev-python/bsddb3 which supports both Python 2 and Python 3."
+ ebeep 6
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"