summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/glib/glib-1.2.10-r4.ebuild')
-rw-r--r--dev-libs/glib/glib-1.2.10-r4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-1.2.10-r4.ebuild b/dev-libs/glib/glib-1.2.10-r4.ebuild
new file mode 100644
index 000000000000..f275ff034e19
--- /dev/null
+++ b/dev-libs/glib/glib-1.2.10-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r4.ebuild,v 1.1 2002/03/21 13:19:56 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GLib library of C routines"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${P}.tar.gz
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/glib/${P}.tar.gz"
+HOMEPAGE="http://www.gtk.org/"
+
+DEPEND="virtual/glibc"
+SLOT="1"
+
+src_compile() {
+ local myconf
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-threads=posix \
+ --enable-debug=yes || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ ( cd ${D}/usr/lib ; chmod 755 libgmodule-1.2.so.* )
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
+
+ dohtml -r docs
+}