summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnl/libnl-1.1.3.ebuild')
-rw-r--r--dev-libs/libnl/libnl-1.1.3.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-libs/libnl/libnl-1.1.3.ebuild b/dev-libs/libnl/libnl-1.1.3.ebuild
deleted file mode 100644
index ee3dffefb1a6..000000000000
--- a/dev-libs/libnl/libnl-1.1.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-1.1.3.ebuild,v 1.13 2013/06/02 08:44:22 ago Exp $
-
-EAPI=5
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="A collection of libraries providing APIs to netlink protocol based Linux kernel interfaces"
-HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
-SRC_URI="http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="1.1"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="doc? ( app-doc/doxygen )"
-DOCS=( ChangeLog )
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.1-vlan-header.patch \
- "${FILESDIR}"/${PN}-1.1-flags.patch \
- "${FILESDIR}"/${PN}-1.1.3-offsetof.patch
- sed -i \
- -e '/@echo/d' \
- Makefile.rules {lib,src,tests}/Makefile || die
- sed -i \
- -e 's|-g ||g' \
- Makefile.opts.in || die
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-
- if use doc ; then
- cd "${S}/doc"
- emake gendoc || die
- fi
-}
-
-src_install() {
- default
-
- if use doc ; then
- cd "${S}/doc"
- dohtml -r html/*
- fi
-}