summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libsigc++/libsigc++-2.2.5.ebuild')
-rw-r--r--dev-libs/libsigc++/libsigc++-2.2.5.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libsigc++/libsigc++-2.2.5.ebuild b/dev-libs/libsigc++/libsigc++-2.2.5.ebuild
new file mode 100644
index 000000000000..180b2d01004f
--- /dev/null
+++ b/dev-libs/libsigc++/libsigc++-2.2.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.2.5.ebuild,v 1.1 2010/03/31 23:14:20 eva Exp $
+
+EAPI="2"
+
+inherit base eutils gnome.org flag-o-matic
+
+DESCRIPTION="Typesafe callback system for standard C++"
+HOMEPAGE="http://libsigc.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+# Needs mm-common for eautoreconf
+src_prepare() {
+ # don't waste time building examples
+ sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' Makefile.in || \
+ die "sed examples failed"
+
+ # don't waste time building tests unless USE=test
+ if ! use test ; then
+ sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' Makefile.in || \
+ die "sed tests failed"
+ fi
+}
+
+src_configure() {
+ filter-flags -fno-exceptions
+
+ local myconf="$myconf $(use_enable doc documentation)"
+
+ econf ${myconf} || die "econf failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed."
+ dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/* || die "dohtml failed"
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "To allow parallel installation of sigc++-1.0, sigc++-1.2, and sigc++2.0"
+ ewarn "the header files are now installed in a version specific"
+ ewarn "subdirectory. Be sure to unmerge any libsigc++ versions"
+ ewarn "< 1.0.4 that you may have previously installed."
+}