summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/nspr/ChangeLog10
-rw-r--r--dev-libs/nspr/files/digest-nspr-4.6.4-r13
-rw-r--r--dev-libs/nspr/files/nspr-4.6.4-config-2.patch32
-rw-r--r--dev-libs/nspr/nspr-4.6.4-r1.ebuild102
4 files changed, 145 insertions, 2 deletions
diff --git a/dev-libs/nspr/ChangeLog b/dev-libs/nspr/ChangeLog
index cfa66c23b2b3..31b14f382788 100644
--- a/dev-libs/nspr/ChangeLog
+++ b/dev-libs/nspr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nspr
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.60 2006/12/21 22:13:23 alonbl Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.61 2007/01/05 21:43:27 alonbl Exp $
+
+*nspr-4.6.4-r1 (05 Jan 2007)
+
+ 05 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/nspr-4.6.4-config-2.patch, +nspr-4.6.4-r1.ebuild:
+ Remove gnuconfig eclass usage, bug#160184
*nspr-4.6.4 (21 Dec 2006)
diff --git a/dev-libs/nspr/files/digest-nspr-4.6.4-r1 b/dev-libs/nspr/files/digest-nspr-4.6.4-r1
new file mode 100644
index 000000000000..bda30b21c53b
--- /dev/null
+++ b/dev-libs/nspr/files/digest-nspr-4.6.4-r1
@@ -0,0 +1,3 @@
+MD5 43db60ab2ff1599c17d3a3f55caa7d47 nspr-4.6.4.tar.gz 1301886
+RMD160 d893554bc49c13787ec33bd2c7580f51bf8e89ac nspr-4.6.4.tar.gz 1301886
+SHA256 49e12321adb3eacf8dac5f799ab52fb1a797021fcb2893736e7bfbd517a02413 nspr-4.6.4.tar.gz 1301886
diff --git a/dev-libs/nspr/files/nspr-4.6.4-config-2.patch b/dev-libs/nspr/files/nspr-4.6.4-config-2.patch
new file mode 100644
index 000000000000..843927c25636
--- /dev/null
+++ b/dev-libs/nspr/files/nspr-4.6.4-config-2.patch
@@ -0,0 +1,32 @@
+--- configure.in.org 2007-01-05 23:07:18.000000000 +0200
++++ configure.in 2007-01-05 23:37:36.000000000 +0200
+@@ -409,7 +409,8 @@ if test "$target" != "$host"; then
+
+ AC_MSG_CHECKING([whether the $host compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
+ AC_TRY_COMPILE([], [return(0);],
+- [ac_cv_prog_host_cc_works=1 AC_MSG_RESULT([yes])],
++ [ac_cv_prog_host_cc_works=1
++ AC_MSG_RESULT([yes])],
+ AC_MSG_ERROR([installation or configuration problem: $host compiler $HOST_CC cannot create executables.]) )
+
+ CC=$_SAVE_CC
+@@ -2155,9 +2156,8 @@ case $target in
+ *-darwin*)
+ ;;
+ *)
+- AC_CHECK_LIB(dl, dlopen,
+- AC_CHECK_HEADER(dlfcn.h,
+- OS_LIBS="-ldl $OS_LIBS"))
++ AC_CHECK_HEADER(dlfcn.h)
++ AC_CHECK_LIB(dl, dlopen, [OS_LIBS="-ldl $OS_LIBS"])
+ ;;
+ esac
+
+@@ -2766,6 +2766,7 @@ config/autoconf.mk
+ config/nsprincl.mk
+ config/nsprincl.sh
+ config/nspr-config
++config/nspr.pc
+ lib/Makefile
+ lib/ds/Makefile
+ lib/libc/Makefile
diff --git a/dev-libs/nspr/nspr-4.6.4-r1.ebuild b/dev-libs/nspr/nspr-4.6.4-r1.ebuild
new file mode 100644
index 000000000000..b2db74537d5a
--- /dev/null
+++ b/dev-libs/nspr/nspr-4.6.4-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.6.4-r1.ebuild,v 1.1 2007/01/05 21:43:27 alonbl Exp $
+
+WANT_AUTOMAKE='latest'
+WANT_AUTOCONF='latest'
+
+inherit eutils autotools
+
+DESCRIPTION="Netscape Portable Runtime"
+HOMEPAGE="http://www.mozilla.org/projects/nspr/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v${PV}/src/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 debug"
+
+DEPEND=""
+S="${WORKDIR}/${P}/mozilla/nsprpub"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_OPTS="-p2" epatch "${FILESDIR}"/${PN}-4.6.1-config.patch
+ EPATCH_OPTS="-p2" epatch "${FILESDIR}"/${PN}-4.6.1-config-1.patch
+ epatch "${FILESDIR}"/${PN}-4.6.4-config-2.patch
+ EPATCH_OPTS="-p2" epatch "${FILESDIR}"/${PN}-4.6.1-lang.patch
+ EPATCH_OPTS="-p2" epatch "${FILESDIR}"/${PN}-4.6.1-prtime.patch
+ eautoreconf
+}
+
+src_compile() {
+ cd "${S}/build"
+
+ if use amd64 || use ppc64 || use ia64 || use s390; then
+ myconf="${myconf} --enable-64bit"
+ else
+ myconf=""
+ fi
+
+ if use ipv6; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ ../configure \
+ --build=${CBUILD:-${CHOST}} \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir)/nspr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $(use_enable debug) \
+ ${myconf} || die "./configure failed"
+ make || die
+}
+
+src_install () {
+ # Their build system is royally fucked, as usual
+ MINOR_VERSION=6
+ cd ${S}/build
+ make install
+ insinto /usr
+ doins -r dist/*
+ rm -rf ${D}/usr/bin/lib*.so
+
+ #removing includes/nspr/md as per fedora spec
+ # i.e a waste of space!
+ rm -rf ${D}/usr/include/nspr/md
+
+ # there have been /usr/lib/nspr changes (like the ldpath below), but never
+ # have I seen any libraries end up in this directory. lets fix that.
+ # note: I tried doing this fix via the build system. It wont work.
+ if [ ! -e ${D}/usr/lib/nspr ] ; then
+ mkdir -p ${D}/usr/lib/nspr
+ mv ${D}/usr/lib/*so* ${D}/usr/lib/nspr
+ mv ${D}/usr/lib/*\.a ${D}/usr/lib/nspr
+ fi
+ # and while we're at it, lets make it actually use the arch's libdir damnit
+ if [ "lib" != "$(get_libdir)" ] ; then
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+ fi
+ #and while at it move them to files with versions-ending
+ #and link them back :)
+ cd ${D}/usr/$(get_libdir)/nspr
+ for file in *.so; do
+ mv ${file} ${file}.${MINOR_VERSION}
+ ln -s ${file}.${MINOR_VERSION} ${file}
+ done
+ # cope with libraries being in /usr/lib/nspr
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/nspr" > ${D}/etc/env.d/08nspr
+
+ # install nspr-config
+ insinto /usr/bin
+ doins ${S}/build/config/nspr-config
+ chmod a+x ${D}/usr/bin/nspr-config
+
+ # create pkg-config file
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins ${S}/build/config/nspr.pc
+}