summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/clisp/clisp-2.33.ebuild')
-rw-r--r--dev-lisp/clisp/clisp-2.33.ebuild63
1 files changed, 30 insertions, 33 deletions
diff --git a/dev-lisp/clisp/clisp-2.33.ebuild b/dev-lisp/clisp/clisp-2.33.ebuild
index 0c1f01fe9e65..df037726d915 100644
--- a/dev-lisp/clisp/clisp-2.33.ebuild
+++ b/dev-lisp/clisp/clisp-2.33.ebuild
@@ -1,41 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33.ebuild,v 1.3 2004/03/30 20:58:13 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.33.ebuild,v 1.4 2004/04/25 20:54:43 vapier Exp $
inherit flag-o-matic common-lisp-common
-IUSE="X fastcgi postgres nls berkdb pcre"
-
-# Handle the case where the user has some other -falign-functions
-# option set. Bug 34630.
-
-if ! is-flag '-falign-functions=4' \
- && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
- CFLAGS=${CFLAGS/\
-$(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
--falign-functions=4}
-fi
-
-# Fails to compile without -falign-functions=4 when -march=pentium4
-# (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
-
-if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
- && ! is-flag '-falign-functions=4'; then
- append-flags '-falign-functions=4'
-fi
-
-# Athlon XP users report problems with -O3 optimization. In this
-# block, we remove any optimization flag. Depending on bug 34497. we
-# may be able to reduce optimization to -O2.
-
-if is-flag '-march=athlon-xp'; then
- filter-flags '-O*'
-fi
-
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="http://clisp.sourceforge.net/"
SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-S=${WORKDIR}/${P}
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86"
+IUSE="X fastcgi postgres nls berkdb pcre"
+
DEPEND="dev-libs/libsigsegv
dev-lisp/common-lisp-controller
fastcgi? ( dev-libs/fcgi )
@@ -45,9 +22,6 @@ DEPEND="dev-libs/libsigsegv
nls? ( sys-devel/gettext )
berkdb? ( =sys-libs/db-4* )
pcre? ( dev-libs/libpcre )"
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="x86"
src_unpack() {
unpack ${A}
@@ -56,6 +30,29 @@ src_unpack() {
}
src_compile() {
+ # Handle the case where the user has some other -falign-functions
+ # option set. Bug 34630.
+ if ! is-flag '-falign-functions=4' \
+ && expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)' >/dev/null; then
+ CFLAGS=${CFLAGS/\
+ $(expr "$CFLAGS" : '.*\(-falign-functions=[[:digit:]]\+\)')/\
+ -falign-functions=4}
+ fi
+
+ # Fails to compile without -falign-functions=4 when -march=pentium4
+ # (or -march=pentium3, sometimes??) is defined. Bugs 33425 and 34630.
+ if (is-flag '-march=pentium4' || is-flag '-march=pentium3') \
+ && ! is-flag '-falign-functions=4'; then
+ append-flags '-falign-functions=4'
+ fi
+
+ # Athlon XP users report problems with -O3 optimization. In this
+ # block, we remove any optimization flag. Depending on bug 34497. we
+ # may be able to reduce optimization to -O2.
+ if is-flag '-march=athlon-xp'; then
+ filter-flags '-O*'
+ fi
+
einfo "Using CFLAGS: ${CFLAGS}"
export CC="${CC} ${CFLAGS}"
unset CFLAGS CXXFLAGS