summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DB_File')
-rw-r--r--dev-perl/DB_File/DB_File-1.73.ebuild3
-rwxr-xr-xdev-perl/DB_File/files/config.in97
2 files changed, 99 insertions, 1 deletions
diff --git a/dev-perl/DB_File/DB_File-1.73.ebuild b/dev-perl/DB_File/DB_File-1.73.ebuild
index ec78eb25139a..b2f98d1d43cc 100644
--- a/dev-perl/DB_File/DB_File-1.73.ebuild
+++ b/dev-perl/DB_File/DB_File-1.73.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DB_File/DB_File-1.73.ebuild,v 1.2 2000/12/15 07:29:29 jerry Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DB_File/DB_File-1.73.ebuild,v 1.3 2001/01/19 02:36:51 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -14,6 +14,7 @@ DEPEND=">=sys-devel/perl-5
src_compile() {
+ cp ${FILESDIR}/config.in .
perl Makefile.PL
try make
try make test
diff --git a/dev-perl/DB_File/files/config.in b/dev-perl/DB_File/files/config.in
new file mode 100755
index 000000000000..103275814a8e
--- /dev/null
+++ b/dev-perl/DB_File/files/config.in
@@ -0,0 +1,97 @@
+# Filename: config.in
+#
+# written by Paul Marquess <Paul.Marquess@btinternet.com>
+# last modified 9th Sept 1997
+# version 1.55
+
+# 1. Where is the file db.h?
+#
+# Change the path below to point to the directory where dh.h is
+# installed on your system.
+
+INCLUDE = /usr/include/db1
+#INCLUDE = /usr/local/BerkeleyDB/include
+#INCLUDE = ./libraries/3.0.55
+
+# 2. Where is libdb?
+#
+# Change the path below to point to the directory where libdb is
+# installed on your system.
+
+LIB = /usr/lib
+#LIB = /usr/local/BerkeleyDB/lib
+#LIB = ./libraries/3.0.55
+
+# 3. What version of Berkely DB have you got?
+#
+# If you have version 2.0 or greater, you can skip this question.
+#
+# If you have Berkeley DB 1.78 or greater you shouldn't have to
+# change the definitions for PREFIX and HASH below.
+#
+# For older versions of Berkeley DB change both PREFIX and HASH to int.
+# Version 1.71, 1.72 and 1.73 are known to need this change.
+#
+# If you don't know what version you have have a look in the file db.h.
+#
+# Search for the string "DB_VERSION_MAJOR". If it is present, you
+# have Berkeley DB version 2 (or greater).
+#
+# If that didn't work, find the definition of the BTREEINFO typedef.
+# Check the return type from the prefix element. It should look like
+# this in an older copy of db.h:
+#
+# int (*prefix) __P((const DBT *, const DBT *));
+#
+# and like this in a more recent copy:
+#
+# size_t (*prefix) /* prefix function */
+# __P((const DBT *, const DBT *));
+#
+# Change the definition of PREFIX, below, to reflect the return type
+# of the prefix function in your db.h.
+#
+# Now find the definition of the HASHINFO typedef. Check the return
+# type of the hash element. Older versions look like this:
+#
+# int (*hash) __P((const void *, size_t));
+#
+# newer like this:
+#
+# u_int32_t /* hash function */
+# (*hash) __P((const void *, size_t));
+#
+# Change the definition of HASH, below, to reflect the return type of
+# the hash function in your db.h.
+#
+
+PREFIX = size_t
+HASH = u_int32_t
+
+# 4. Is the library called libdb?
+#
+# If you have copies of both 1.x and 2.x Berkeley DB installed on
+# your system it can sometimes be tricky to make sure you are using
+# the correct one. Renaming one (or creating a symbolic link) to
+# include the version number of the library can help.
+#
+# For example, if you have both Berkeley DB 2.3.12 and 1.85 on your
+# system and you want to use the Berkeley DB version 2 library you
+# could rename the version 2 library from libdb.a to libdb-2.3.12.a and
+# change the DBNAME line below to look like this:
+#
+# DBNAME = -ldb-2.3.12
+#
+# That will ensure you are linking the correct version of the DB
+# library.
+#
+# Note: If you are building this module with Win32, -llibdb will be
+# used by default.
+#
+# If you have changed the name of the library, uncomment the line
+# below (by removing the leading #) and edit the line to use the name
+# you have picked.
+
+DBNAME = -ldb1
+
+# end of file config.in