summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/basemap/files/basemap-0.99-syslib.patch')
-rw-r--r--dev-python/basemap/files/basemap-0.99-syslib.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/basemap/files/basemap-0.99-syslib.patch b/dev-python/basemap/files/basemap-0.99-syslib.patch
new file mode 100644
index 000000000000..33aa706a6c2d
--- /dev/null
+++ b/dev-python/basemap/files/basemap-0.99-syslib.patch
@@ -0,0 +1,45 @@
+--- setup.py.orig 2008-07-02 17:17:56.980035282 +0100
++++ setup.py 2008-07-02 17:49:26.354807468 +0100
+@@ -26,7 +26,7 @@
+ DBFUpdateHeader is available, we scan shapefil.h for the string
+ 'DBFUpdateHeader'.
+ """
+- f = open(convert_path("pyshapelib/shapelib/shapefil.h"))
++ f = open(convert_path("/usr/include/libshp/shapefil.h"))
+ contents = f.read()
+ f.close()
+ if contents.find("DBFUpdateHeader") >= 0:
+@@ -55,7 +55,7 @@
+
+ if GEOS_dir is None:
+ # if GEOS_dir not set, check a few standard locations.
+- GEOS_dirs = ['/usr/local','/sw','/opt','/opt/local',os.path.expanduser('~')]
++ GEOS_dirs = ['/usr','/usr/local','/sw','/opt','/opt/local',os.path.expanduser('~')]
+ for direc in GEOS_dirs:
+ geos_version = checkversion(direc)
+ print 'checking for GEOS lib in %s ....' % direc
+@@ -104,17 +104,16 @@
+ package_dirs['dbflib'] = os.path.join('lib','dbflib')
+ extensions = extensions + \
+ [Extension("shapelibc",
+- ["pyshapelib/shapelib_wrap.c",
+- "pyshapelib/shapelib/shpopen.c",
+- "pyshapelib/shapelib/shptree.c"],
+- include_dirs = ["pyshapelib/shapelib"]),
++ ["pyshapelib/shapelib_wrap.c"],
++ include_dirs = ["/usr/include/libshp"],
++ libraries = ["shp"]),
+ Extension("shptree",
+ ["pyshapelib/shptreemodule.c"],
+- include_dirs = ["pyshapelib/shapelib"]),
++ include_dirs = ["/usr/include/libshp"]),
+ Extension("dbflibc",
+- ["pyshapelib/dbflib_wrap.c",
+- "pyshapelib/shapelib/dbfopen.c"],
+- include_dirs = ["pyshapelib/shapelib"],
++ ["pyshapelib/dbflib_wrap.c"],
++ include_dirs = ["/usr/include/libshp"],
++ libraries = ["shp"],
+ define_macros = dbf_macros()) ]
+
+ # check setup.cfg file to see how to install auxilliary packages.