summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cherrypy/cherrypy-2.2.1.ebuild')
-rw-r--r--dev-python/cherrypy/cherrypy-2.2.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/cherrypy/cherrypy-2.2.1.ebuild b/dev-python/cherrypy/cherrypy-2.2.1.ebuild
deleted file mode 100644
index 335d569e0d45..000000000000
--- a/dev-python/cherrypy/cherrypy-2.2.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-2.2.1.ebuild,v 1.3 2007/02/27 22:47:19 dev-zero Exp $
-
-inherit distutils
-
-MY_P=CherryPy-${PV}
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
-SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
-HOMEPAGE="http://www.cherrypy.org/"
-IUSE="doc"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-LICENSE="BSD"
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i \
- -e '/raw_input/d' \
- cherrypy/test/test.py || die "sed failed"
- sed -i \
- -e 's/"cherrypy.tutorial",//' \
- -e "/('cherrypy\/tutorial',/, /),/d" \
- setup.py || die "sed failed"
-
-}
-
-src_install() {
- distutils_src_install
- if use doc ; then
- insinto /usr/share/doc/${PF}
- doins -r cherrypy/tutorial
- fi
-}
-
-src_test() {
- PYTHONPATH=. "${python}" cherrypy/test/test.py || die "test failed"
-}