summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cherrypy/cherrypy-3.0.2.ebuild')
-rw-r--r--dev-python/cherrypy/cherrypy-3.0.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/cherrypy/cherrypy-3.0.2.ebuild b/dev-python/cherrypy/cherrypy-3.0.2.ebuild
new file mode 100644
index 000000000000..6caab957a7ba
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-3.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.0.2.ebuild,v 1.1 2007/09/04 09:22:30 lucass Exp $
+
+inherit distutils
+
+MY_P=CherryPy-${PV}
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
+SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cherrypy.org/"
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+LICENSE="BSD"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/"cherrypy.tutorial",//' \
+ -e "/('cherrypy\/tutorial',/, /),/d" \
+ setup.py || die "sed failed"
+
+}
+
+src_install() {
+ distutils_src_install
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r cherrypy/tutorial
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" cherrypy/test/test.py --dumb || die "test failed"
+}