summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gdata/gdata-2.0.0.ebuild')
-rw-r--r--dev-python/gdata/gdata-2.0.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/gdata/gdata-2.0.0.ebuild b/dev-python/gdata/gdata-2.0.0.ebuild
new file mode 100644
index 000000000000..ffa9545703da
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.0.ebuild,v 1.1 2009/07/10 19:53:23 arfrever Exp $
+
+inherit distutils eutils
+
+MY_P="gdata-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
+
+PYTHON_MODNAME="atom gdata"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+src_test() {
+ cd tests
+ export PYTHONPATH=../src
+ "${python}" run_data_tests.py -v || die "Data tests failed"
+
+ # run_service_tests.py requires interaction (and a valid google account), so skip.
+ #"${python}" run_service_tests.py -v || die "Service tests failed"
+}