summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gnome-python/gnome-python-2.6.1.ebuild')
-rw-r--r--dev-python/gnome-python/gnome-python-2.6.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/gnome-python/gnome-python-2.6.1.ebuild b/dev-python/gnome-python/gnome-python-2.6.1.ebuild
new file mode 100644
index 000000000000..69df6cfd479f
--- /dev/null
+++ b/dev-python/gnome-python/gnome-python-2.6.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-2.6.1.ebuild,v 1.1 2004/11/24 15:48:29 liquidx Exp $
+
+inherit gnome2 python eutils
+
+DESCRIPTION="GNOME 2 bindings for Python"
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+
+IUSE="gtkhtml"
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
+
+RDEPEND=">=dev-lang/python-2.2
+ >=dev-python/pygtk-2.4
+ >=dev-python/pyorbit-2.0.1
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomecanvas-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/gconf-1.2
+ >=x11-libs/libzvt-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/nautilus-2
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ gtkhtml? ( =gnome-extra/libgtkhtml-2* )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ #cd ${S}
+ #epatch ${FILESDIR}/${P}-gtkhtml.patch
+ #epatch ${FILESDIR}/${P}-gtkhtml-atomic.patch
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/doc/${P}
+ doins -r examples
+
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}
+