summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpatch/jsonpatch-0.10.ebuild')
-rw-r--r--dev-python/jsonpatch/jsonpatch-0.10.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/jsonpatch-0.10.ebuild b/dev-python/jsonpatch/jsonpatch-0.10.ebuild
new file mode 100644
index 000000000000..0c75241e76c1
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-0.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpatch/jsonpatch-0.10.ebuild,v 1.1 2013/01/20 06:18:47 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches according to
+http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jsonpointer[${PYTHON_USEDEP}]"