summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numeric/ChangeLog8
-rw-r--r--dev-python/numeric/Manifest3
-rw-r--r--dev-python/numeric/files/digest-numeric-23.31
-rw-r--r--dev-python/numeric/files/numeric-23.3.patch52
-rw-r--r--dev-python/numeric/numeric-23.3.ebuild38
5 files changed, 101 insertions, 1 deletions
diff --git a/dev-python/numeric/ChangeLog b/dev-python/numeric/ChangeLog
index 5163a078b0be..164f4477b8f5 100644
--- a/dev-python/numeric/ChangeLog
+++ b/dev-python/numeric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/numeric
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/ChangeLog,v 1.7 2004/06/25 01:35:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/ChangeLog,v 1.8 2004/08/18 18:27:31 kloeri Exp $
+
+*numeric-23.3 (18 Aug 2004)
+
+ 18 Aug 2004; Bryan Østergaard <kloeri@gentoo.org> +files/numeric-23.3.patch,
+ +numeric-23.3.ebuild:
+ Version bump, ebuild by S.Caglar Onur <caglar.onur@tubitak.gov.tr>
31 May 2004; Bryan Østergaard <kloeri@gentoo.org> numeric-23.1.ebuild:
Stable on alpha.
diff --git a/dev-python/numeric/Manifest b/dev-python/numeric/Manifest
index c36282471105..9b0982c1e34e 100644
--- a/dev-python/numeric/Manifest
+++ b/dev-python/numeric/Manifest
@@ -3,6 +3,9 @@ MD5 0e196e3f6656f3aba77f29434067e65e numeric-23.1.ebuild 828
MD5 f1e761b5d85f0acdd1ae9193ff179130 ChangeLog 1920
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 a380ec4d19d310f3fe27156af572e90e numeric-22.0.ebuild 815
+MD5 c8a48b9e01afc8eea69af1aa0d4fc3b6 numeric-23.3.ebuild 806
+MD5 c687dac0db35f8cf31d423d46dd0ced5 files/numeric-23.3.patch 2390
MD5 543b62c79215183872d1f43ee1033c0b files/digest-numeric-22.0 64
MD5 1bbfd6024c1a372499b3774b2b91b5ab files/digest-numeric-23.0 64
MD5 a52c0be4669341bbf82129377ca75f2e files/digest-numeric-23.1 64
+MD5 5d2d3eb0342d757082bce1599b6838de files/digest-numeric-23.3 64
diff --git a/dev-python/numeric/files/digest-numeric-23.3 b/dev-python/numeric/files/digest-numeric-23.3
new file mode 100644
index 000000000000..12c3008d83c9
--- /dev/null
+++ b/dev-python/numeric/files/digest-numeric-23.3
@@ -0,0 +1 @@
+MD5 2cb350a3764e6d1b009d598e4581dede Numeric-23.3.tar.gz 724568
diff --git a/dev-python/numeric/files/numeric-23.3.patch b/dev-python/numeric/files/numeric-23.3.patch
new file mode 100644
index 000000000000..ab152b26ad74
--- /dev/null
+++ b/dev-python/numeric/files/numeric-23.3.patch
@@ -0,0 +1,52 @@
+--- setup.py 2004-08-12 22:15:54.134168680 +0300
++++ setup.py 2004-08-12 22:18:16.398541208 +0300
+@@ -33,20 +33,20 @@
+
+ # delete all but the first one in this list if using your own LAPACK/BLAS
+ sourcelist = [os.path.join('Src', 'lapack_litemodule.c'),
+-# os.path.join('Src', 'blas_lite.c'),
+-# os.path.join('Src', 'f2c_lite.c'),
+-# os.path.join('Src', 'zlapack_lite.c'),
+-# os.path.join('Src', 'dlapack_lite.c')
++ os.path.join('Src', 'blas_lite.c'),
++ os.path.join('Src', 'f2c_lite.c'),
++ os.path.join('Src', 'zlapack_lite.c'),
++ os.path.join('Src', 'dlapack_lite.c')
+ ]
+ # set these to use your own BLAS;
+
+-library_dirs_list = ['/usr/lib/atlas']
+-libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
++#library_dirs_list = ['/usr/lib/atlas']
++#libraries_list = ['lapack_lite', 'cblas', 'f77blas', 'atlas', 'g2c']
+ # if you also set `use_dotblas` (see below), you'll need:
+ # ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
+
+ # set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct
+-use_dotblas = 1
++use_dotblas = 0
+ include_dirs = ['/usr/include/atlas'] # You may need to set this to find cblas.h
+ # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
+
+@@ -80,8 +80,8 @@
+ os.path.join('Src', 'linpack.c')],
+ extra_compile_args = extra_compile_args),
+ Extension('lapack_lite', sourcelist,
+- library_dirs = library_dirs_list,
+- libraries = libraries_list,
++# library_dirs = library_dirs_list,
++# libraries = libraries_list,
+ extra_compile_args = extra_compile_args)
+ ]
+
+@@ -113,8 +113,8 @@
+ package_dir['dotblas'] = os.path.join('Packages', 'dotblas', 'dotblas')
+ ext_modules.append(Extension('_dotblas',
+ [os.path.join('Packages', 'dotblas', 'dotblas', '_dotblas.c')],
+- library_dirs = library_dirs_list,
+- libraries = libraries_list,
++# library_dirs = library_dirs_list,
++# libraries = libraries_list,
+ extra_compile_args=extra_compile_args))
+
+
diff --git a/dev-python/numeric/numeric-23.3.ebuild b/dev-python/numeric/numeric-23.3.ebuild
new file mode 100644
index 000000000000..ff21a09b6565
--- /dev/null
+++ b/dev-python/numeric/numeric-23.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/numeric-23.3.ebuild,v 1.1 2004/08/18 18:27:31 kloeri Exp $
+
+inherit distutils eutils
+
+MY_P=${P/n/N}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Numerical Python adds a fast, compact, multidimensional array language facility to Python."
+SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+LICENSE="as-is"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_install() {
+
+ distutils_src_install
+ distutils_python_version
+
+ #Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${PYVER}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}