summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild')
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild b/dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild
new file mode 100644
index 000000000000..3a7bd8144cc9
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.5-r4.ebuild,v 1.1 2010/02/01 16:40:29 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.12 >=dev-ruby/i18n-0.1.3:0.1"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as
+ # well as fixing the dependencies for i18n to use only the 0.1
+ # slot.
+ epatch "${FILESDIR}"/${P}-unvendorize.patch
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${P}-mocha-0.9.5.patch
+}