summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/patron/patron-0.4.18.ebuild')
-rw-r--r--dev-ruby/patron/patron-0.4.18.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/patron/patron-0.4.18.ebuild b/dev-ruby/patron/patron-0.4.18.ebuild
deleted file mode 100644
index c3adb8a30c4e..000000000000
--- a/dev-ruby/patron/patron-0.4.18.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.18.ebuild,v 1.3 2013/01/01 09:04:20 ago Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_EXTRADOC="README.txt"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
-HOMEPAGE="http://toland.github.com/patron/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
-
-DEPEND="${DEPEND} net-misc/curl"
-RDEPEND="${RDEPEND} net-misc/curl"
-
-# Tests require a live web service that is not included in the distribution.
-RESTRICT="test"
-
-each_ruby_configure() {
- ${RUBY} -Cext/patron extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -Cext/patron || die
- cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
-}