summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/stringex/stringex-2.4.2.ebuild')
-rw-r--r--dev-ruby/stringex/stringex-2.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/stringex/stringex-2.4.2.ebuild b/dev-ruby/stringex/stringex-2.4.2.ebuild
new file mode 100644
index 000000000000..1b43126a1ea1
--- /dev/null
+++ b/dev-ruby/stringex/stringex-2.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stringex/stringex-2.4.2.ebuild,v 1.1 2014/03/27 02:33:32 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_DOC_DIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extensions for Ruby's String class"
+HOMEPAGE="http://github.com/rsl/stringex"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# we could rely on activerecord[sqlite3], but since we do not remove the
+# sqlite3 adapter from activerecord when building -sqlite3, it's easier
+# to just add another dependency, so the user doesn't have to change the
+# USE flags at all.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/activerecord:3.2
+ dev-ruby/sqlite3
+ dev-ruby/redcloth
+ dev-ruby/test-unit:2
+ )"
+
+each_ruby_test() {
+ # rake seems to break this
+ ruby-ng_testrb-2 -Ilib -Itest test/{unit,performance}/**/*_test.rb || die "tests failed"
+}