summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/splint/splint-3.1.2-r1.ebuild')
-rw-r--r--dev-util/splint/splint-3.1.2-r1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-util/splint/splint-3.1.2-r1.ebuild b/dev-util/splint/splint-3.1.2-r1.ebuild
index d81bd03f7eb5..071ac9be2a18 100644
--- a/dev-util/splint/splint-3.1.2-r1.ebuild
+++ b/dev-util/splint/splint-3.1.2-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/splint-3.1.2-r1.ebuild,v 1.2 2014/06/18 13:43:06 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/splint-3.1.2-r1.ebuild,v 1.3 2014/07/01 18:50:30 jer Exp $
EAPI=5
+inherit autotools
DESCRIPTION="Check C programs for vulnerabilities and programming mistakes"
HOMEPAGE="http://lclint.cs.virginia.edu/"
@@ -16,6 +17,17 @@ DEPEND="
sys-devel/flex
"
+src_prepare() {
+ # verbose compiler calls
+ sed -i -e '/Compiling/d' src/Makefile.am || die
+ # automake complains about trailing \
+ sed -i -e '1600d' test/Makefile.am || die
+ # do not install these header files twice
+ sed -i -e '/\$(UnixHeaders)/s|stdio.h stdlib.h||g' lib/Makefile.am || die
+
+ eautoreconf
+}
+
src_configure() {
# We do not need bison/yacc at all here
# We definitely need libfl