summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/cavezofphear/files/cavezofphear-0.5-gentoo.patch')
-rw-r--r--games-arcade/cavezofphear/files/cavezofphear-0.5-gentoo.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/games-arcade/cavezofphear/files/cavezofphear-0.5-gentoo.patch b/games-arcade/cavezofphear/files/cavezofphear-0.5-gentoo.patch
new file mode 100644
index 000000000000..d7ffa2e4237c
--- /dev/null
+++ b/games-arcade/cavezofphear/files/cavezofphear-0.5-gentoo.patch
@@ -0,0 +1,24 @@
+--- src/Makefile.old 2009-01-30 17:22:01.000000000 +0100
++++ src/Makefile 2009-01-30 17:24:52.000000000 +0100
+@@ -2,10 +2,8 @@
+
+ DESTDIR = ..
+
+-CC = gcc
+ INSTALL = install
+-CFLAGS = -s -Wall -O2
+-LDFLAGS = -lncurses
++LDLIBS = -lncurses
+
+ all: phear install clean
+
+@@ -13,7 +11,7 @@
+ $(CC) $(CFLAGS) -c $^ -o $@
+
+ phear: $(OBJS)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LDLIBS)
+
+ install: install-game
+
+