summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/scid/scid-3.6.1-r2.ebuild')
-rw-r--r--games-board/scid/scid-3.6.1-r2.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/games-board/scid/scid-3.6.1-r2.ebuild b/games-board/scid/scid-3.6.1-r2.ebuild
new file mode 100644
index 000000000000..3631884d2383
--- /dev/null
+++ b/games-board/scid/scid-3.6.1-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/scid-3.6.1-r2.ebuild,v 1.1 2007/08/30 10:49:10 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="a free chess database application"
+HOMEPAGE="http://scid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scid/${P}.tar.gz
+ mirror://sourceforge/scid/photos.zip
+ mirror://sourceforge/scid/ratings.zip
+ mirror://sourceforge/scid/scidlet40k.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/tk-8.3
+ >=sys-libs/zlib-1.1.3"
+RDEPEND="${DEPEND}
+ x11-libs/libX11
+ >=dev-lang/python-2.1"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@snack_path@:/lib/snack2.2:" \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ tcl/start.tcl
+}
+
+src_compile() {
+ ./configure \
+ COMPILE=c++ \
+ LINK=c++ \
+ BINDIR=/usr/bin \
+ OPTIMIZE="${CXXFLAGS}" \
+ TCL_INCLUDE=""
+
+ # buggy makefiles bug #46110
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dogamesbin pgnfix pgnscid sc_addmove sc_eco sc_epgn sc_import sc_remote \
+ sc_spell sc_tree scid scidpgn scmerge spliteco tcscid tkscid scidlet \
+ || die "dogamesbin failed"
+
+ dodoc CHANGES README THANKS
+ dohtml help/*.html
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r scid.eco sounds spelling.ssp \
+ ../{gm.spf,historic.spf,ratings.ssp,scidlet40k.sbk} \
+ || die "doins failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To enable speech, just emerge dev-tcltk/snack"
+}