summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dosbox/dosbox-0.72.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-0.72.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/games-emulation/dosbox/dosbox-0.72.ebuild b/games-emulation/dosbox/dosbox-0.72.ebuild
index 4c17a72aaeee..35e4a73ba797 100644
--- a/games-emulation/dosbox/dosbox-0.72.ebuild
+++ b/games-emulation/dosbox/dosbox-0.72.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.72.ebuild,v 1.5 2007/10/22 04:28:46 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.72.ebuild,v 1.6 2008/06/13 16:34:56 flameeyes Exp $
inherit eutils games
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 ~sparc x86"
IUSE="alsa debug hardened opengl"
-DEPEND="media-libs/alsa-lib
+DEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/opengl )
debug? ( sys-libs/ncurses )
media-libs/libpng
@@ -22,7 +22,7 @@ DEPEND="media-libs/alsa-lib
media-libs/sdl-sound"
pkg_setup() {
- if ! built_with_use --missing true media-libs/alsa-lib midi; then
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
eerror "To be able to build dosbox with ALSA support you need"
eerror "to have built media-libs/alsa-lib with midi USE flag."
die "Missing midi USE flag on media-libs/alsa-lib"
@@ -30,9 +30,17 @@ pkg_setup() {
games_pkg_setup
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}+gcc-4.3.patch"
+}
+
src_compile() {
egamesconf \
--disable-dependency-tracking \
+ $(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-x86) \
$(use_enable debug) \
$(use_enable opengl) \