summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/fceultra/fceultra-0.98.10.ebuild')
-rw-r--r--games-emulation/fceultra/fceultra-0.98.10.ebuild43
1 files changed, 19 insertions, 24 deletions
diff --git a/games-emulation/fceultra/fceultra-0.98.10.ebuild b/games-emulation/fceultra/fceultra-0.98.10.ebuild
index 7d0b9b95d31a..6fd56c904374 100644
--- a/games-emulation/fceultra/fceultra-0.98.10.ebuild
+++ b/games-emulation/fceultra/fceultra-0.98.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/fceultra-0.98.10.ebuild,v 1.1 2004/05/29 22:25:59 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fceultra/fceultra-0.98.10.ebuild,v 1.2 2004/06/05 07:34:28 mr_bones_ Exp $
-inherit games gcc eutils
+inherit eutils games
DESCRIPTION="A portable NES/Famicom emulator"
HOMEPAGE="http://fceultra.sourceforge.net/"
@@ -11,38 +11,33 @@ SRC_URI="http://fceultra.sourceforge.net/releases/fceu-${PV}.src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
+IUSE="opengl"
-IUSE="sdl gtk opengl"
-
+RDEPEND="virtual/glibc
+ >=media-libs/libsdl-1.2.0
+ opengl? ( virtual/opengl )
+ sys-libs/zlib"
# Because of code generation bugs, FCEUltra now depends on a version
# of gcc greater than or equal to GCC 3.2.2.
-RDEPEND="|| (
- gtk? ( >=x11-libs/gtk+-2.2.0 )
- sdl? ( >=media-libs/libsdl-1.2.0 )
- opengl? ( virtual/opengl )
- )
- >=sys-devel/gcc-3.2.2
- sys-libs/zlib"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+ >=sys-devel/gcc-3.2.2"
-S=${WORKDIR}/fceu
+S="${WORKDIR}/fceu"
src_compile() {
- local myconf
- use sdl && myconf="${myconf} --with-sdl"
- use gtk && myconf="${myconf} --with-gtk"
- use opengl && myconf="${myconf} --with-opengl"
- egamesconf ${myconf} || die "egamesconf failed"
+ egamesconf \
+ --disable-dependency-tracking \
+ --without-gtk \
+ --disable-gtktest \
+ $(use_with opengl) || die
emake || die "emake failed"
}
src_install() {
- egamesinstall || die "install failed"
- dodoc Documentation/*.txt AUTHORS README NEWS COPYING TODO ChangeLog
- cp -r Documentation/tech "${D}/usr/share/doc/${P}/" || die "cp failed"
- find ${D}/usr/share/doc/${P}/tech -type f -exec gzip -9 \{\} \; || \
- die "find failed"
- dohtml Documentation/* || die "dohtml failed"
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc Documentation/*.txt AUTHORS README NEWS TODO ChangeLog
+ cp -r Documentation/tech "${D}/usr/share/doc/${PF}/" || die "cp failed"
+ prepalldocs
+ dohtml Documentation/*
prepgamesdirs
}