summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/toppler/toppler-1.1.6.ebuild')
-rw-r--r--games-puzzle/toppler/toppler-1.1.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-puzzle/toppler/toppler-1.1.6.ebuild b/games-puzzle/toppler/toppler-1.1.6.ebuild
new file mode 100644
index 000000000000..96610f1b18b8
--- /dev/null
+++ b/games-puzzle/toppler/toppler-1.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/toppler/toppler-1.1.6.ebuild,v 1.1 2013/01/17 18:04:52 mr_bones_ Exp $
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Reimplementation of Nebulous using SDL"
+HOMEPAGE="http://toppler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer[vorbis]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ egamesconf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}