summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/bonobo/bonobo-1.0.4.ebuild')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.4.ebuild b/gnome-base/bonobo/bonobo-1.0.4.ebuild
new file mode 100644
index 000000000000..116208cbdb28
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.4.ebuild,v 1.1 2001/05/17 00:10:07 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=gnome-base/oaf-0.6.5
+ >=gnome-base/ORBit-0.5.8
+ >=gnome-base/gnome-print-0.25"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ # on of the samples in the package need to be regenerated from the idl files
+ rm -f ${S}/samples/bonobo-class/Bonobo_Sample_Echo.h
+ rm -f ${S}/samples/bonobo-class/Bonobo_Sample_Echo-*.c
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
+
+