summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-panel/gnome-panel-2.14.1.ebuild')
-rw-r--r--gnome-base/gnome-panel/gnome-panel-2.14.1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/gnome-base/gnome-panel/gnome-panel-2.14.1.ebuild b/gnome-base/gnome-panel/gnome-panel-2.14.1.ebuild
deleted file mode 100644
index 80d5634b0986..000000000000
--- a/gnome-base/gnome-panel/gnome-panel-2.14.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/gnome-panel-2.14.1.ebuild,v 1.1 2006/04/12 23:13:44 compnerd Exp $
-
-inherit gnome2
-
-DESCRIPTION="The GNOME panel"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2 FDL-1.1 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc eds"
-
-RDEPEND=">=gnome-base/gnome-desktop-2.11.92
- >=x11-libs/gtk+-2.7.1
- >=gnome-base/libglade-2.5
- >=gnome-base/libgnome-2.13
- >=gnome-base/libgnomeui-2.5.4
- >=gnome-base/libbonoboui-2.1.1
- >=gnome-base/orbit-2.4
- >=gnome-base/gnome-vfs-2.9.1
- >=x11-libs/libwnck-2.13.5
- >=gnome-base/gconf-2.6.1
- >=gnome-base/gnome-menus-2.11.1
- >=gnome-base/libbonobo-2
- media-libs/libpng
- x11-libs/cairo
- eds? ( >=gnome-extra/evolution-data-server-1.2 )"
-
-DEPEND="${RDEPEND}
- app-text/scrollkeeper
- >=app-text/gnome-doc-utils-0.3.2
- >=dev-util/pkgconfig-0.9
- >=dev-util/intltool-0.31
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
-pkg_setup() {
- G2CONF="--disable-scrollkeeper \
- $(use_enable eds)"
-}
-
-src_unpack() {
- gnome2_src_unpack
-
- # FIXME : uh yeah, this is nice
- # We should patch in a switch here and send it upstream
- sed -i 's:--load:-v:' ${S}/gnome-panel/Makefile.in || die "sed failed"
-}
-
-pkg_postinst() {
-
- local entries="/etc/gconf/schemas/panel-default-setup.entries"
- if [ -e "$entries" ]; then
- einfo "setting panel gconf defaults..."
- GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
- ${ROOT}/usr/bin/gconftool-2 --direct --config-source \
- ${GCONF_CONFIG_SOURCE} --load=${entries}
- fi
-
- # Calling this late so it doesn't process the GConf schemas file we already
- # took care of.
- gnome2_pkg_postinst
-
-}
-