summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gvfs/gvfs-1.0.3.ebuild')
-rw-r--r--gnome-base/gvfs/gvfs-1.0.3.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnome-base/gvfs/gvfs-1.0.3.ebuild b/gnome-base/gvfs/gvfs-1.0.3.ebuild
index ce5a25d3dbf9..3700f8e1a9ea 100644
--- a/gnome-base/gvfs/gvfs-1.0.3.ebuild
+++ b/gnome-base/gvfs/gvfs-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.3.ebuild,v 1.2 2009/01/20 11:13:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.0.3.ebuild,v 1.3 2009/01/29 22:07:22 eva Exp $
-inherit bash-completion gnome2 eutils
+inherit autotools bash-completion gnome2 eutils
DESCRIPTION="GNOME Virtual Filesystem Layer"
HOMEPAGE="http://www.gnome.org"
@@ -37,7 +37,8 @@ RDEPEND=">=dev-libs/glib-2.17.6
DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
>=dev-util/pkgconfig-0.19
- doc? ( >=dev-util/gtk-doc-1 )"
+ doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/gtk-doc-am"
DOCS="AUTHORS ChangeLog NEWS README TODO"
@@ -64,6 +65,15 @@ pkg_setup() {
fi
}
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix non posixy tests, bug #256305
+ epatch "${FILESDIR}/${P}-posixtest.patch"
+
+ eautoreconf
+}
+
src_install() {
gnome2_src_install
use bash-completion && \