summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/nautilus/nautilus-2.26.3-r1.ebuild')
-rw-r--r--gnome-base/nautilus/nautilus-2.26.3-r1.ebuild96
1 files changed, 0 insertions, 96 deletions
diff --git a/gnome-base/nautilus/nautilus-2.26.3-r1.ebuild b/gnome-base/nautilus/nautilus-2.26.3-r1.ebuild
deleted file mode 100644
index 6cf6a5d4eeed..000000000000
--- a/gnome-base/nautilus/nautilus-2.26.3-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.26.3-r1.ebuild,v 1.1 2009/09/28 13:09:56 mrpouet Exp $
-
-EAPI="2"
-
-inherit gnome2 eutils virtualx
-
-DESCRIPTION="A file manager for the GNOME desktop"
-HOMEPAGE="http://www.gnome.org/projects/nautilus/"
-
-LICENSE="GPL-2 LGPL-2 FDL-1.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="beagle doc gnome tracker xmp"
-
-# not adding gnome-base/gail because it is in gtk+
-RDEPEND=">=dev-libs/glib-2.19.0
- >=gnome-base/gnome-desktop-2.25.5
- >=x11-libs/pango-1.1.2
- >=x11-libs/gtk+-2.16.0
- >=dev-libs/libxml2-2.4.7
- >=media-libs/libexif-0.5.12
- >=gnome-base/gconf-2.0
- >=gnome-base/gvfs-0.1.2
- dev-libs/libunique
- dev-libs/dbus-glib
- x11-libs/libXft
- x11-libs/libXrender
- beagle? ( || (
- dev-libs/libbeagle
- =app-misc/beagle-0.2* ) )
- tracker? ( >=app-misc/tracker-0.6.4 )
- xmp? ( >=media-libs/exempi-2 )"
-
-DEPEND="${RDEPEND}
- >=dev-lang/perl-5
- sys-devel/gettext
- >=dev-util/pkgconfig-0.9
- >=dev-util/intltool-0.40.1
- doc? ( >=dev-util/gtk-doc-1.4 )
- gnome-base/gnome-common
- dev-util/gtk-doc-am"
-
-PDEPEND="gnome? ( >=x11-themes/gnome-icon-theme-1.1.91 )"
-
-DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS TODO"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --disable-update-mimedb
- --disable-packagekit
- $(use_enable beagle)
- $(use_enable tracker)
- $(use_enable xmp)"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # FIXME: tarball generated with broken gtk-doc, revisit me.
- if use doc; then
- sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" \
- -i gtk-doc.make || die "sed 1 failed"
- else
- sed "/^TARGET_DIR/i \GTKDOC_REBASE=/bin/true" \
- -i gtk-doc.make || die "sed 2 failed"
- fi
-
- # gtk-doc-am and gnome-common needed for this
-
- # Fix intltoolize broken file, see upstream #577133
- sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
-
- # Fix nautilus flipping-out with --no-desktop -- bug 266398
- epatch "${FILESDIR}/${PN}-2.26.2-change-reg-desktop-file-with-no-desktop.patch"
- # Fix crash due to duplicate id in .ui file, bug #286312
- epatch "${FILESDIR}/${P}-file-management-properties-ui-dup-id.patch"
- # Fix massive memory consumption by Nautilus for larger zoom levels.
- # Import from upstream, see distributor mailing lists.
- epatch "${FILESDIR}/${P}-thumbnail-zoom-level.patch"
-}
-
-src_test() {
- addwrite "/root/.gnome2_private"
- unset SESSION_MANAGER
- Xemake check || die "Test phase failed"
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- elog "nautilus can use gstreamer to preview audio files. Just make sure"
- elog "to have the necessary plugins available to play the media type you"
- elog "want to preview"
-}