summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/ChangeLog7
-rw-r--r--gnome-base/gconf/files/digest-gconf-2.14.03
-rw-r--r--gnome-base/gconf/files/gconf-2.20.1-drop-gtk-doc.patch33
-rw-r--r--gnome-base/gconf/gconf-2.14.0.ebuild83
-rw-r--r--gnome-base/gconf/gconf-2.20.1-r1.ebuild6
5 files changed, 42 insertions, 90 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 5338b15d0f0d..cd029f994c89 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.180 2008/01/02 07:06:17 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.181 2008/01/26 13:27:25 eva Exp $
+
+ 26 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gconf-2.20.1-drop-gtk-doc.patch, -gconf-2.14.0.ebuild,
+ gconf-2.20.1-r1.ebuild:
+ fix bug #207114 and clean up old revision
02 Jan 2008; Gilles Dartiguelongue <eva@gentoo.org>
gconf-2.20.1-r1.ebuild:
diff --git a/gnome-base/gconf/files/digest-gconf-2.14.0 b/gnome-base/gconf/files/digest-gconf-2.14.0
deleted file mode 100644
index 0be96ef76ea3..000000000000
--- a/gnome-base/gconf/files/digest-gconf-2.14.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d07c2efcaf477cf34225c604a04b6271 GConf-2.14.0.tar.bz2 1895477
-RMD160 4e281fc8046238df2056cbb1c1b068dc9663041b GConf-2.14.0.tar.bz2 1895477
-SHA256 040c512ebc39285bce78c177e9e434e7b6731fd53a001768ee3405a919837525 GConf-2.14.0.tar.bz2 1895477
diff --git a/gnome-base/gconf/files/gconf-2.20.1-drop-gtk-doc.patch b/gnome-base/gconf/files/gconf-2.20.1-drop-gtk-doc.patch
new file mode 100644
index 000000000000..62c2ef855169
--- /dev/null
+++ b/gnome-base/gconf/files/gconf-2.20.1-drop-gtk-doc.patch
@@ -0,0 +1,33 @@
+--- configure.in.old 2008-01-26 11:43:17.423830001 +0100
++++ configure.in 2008-01-26 11:44:23.137155036 +0100
+@@ -129,7 +129,12 @@
+ fi
+ fi
+
+-GTK_DOC_CHECK([1.0])
++dnl Crazy hack for dropping the dep on gtk-doc
++AC_DEFUN(GTK_DOC_CHECK, [])
++
++dnl Crazy hack for dropping the dep on gtk-doc
++AM_CONDITIONAL(ENABLE_GTK_DOC, 0, [])
++AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, 0, [])
+
+ AC_ARG_ENABLE(gtk,
+ AC_HELP_STRING([--enable-gtk],
+Index: Makefile.am
+===================================================================
+--- Makefile.am (révision 2495)
++++ Makefile.am (copie de travail)
+@@ -1,7 +1,11 @@
+
+-SUBDIRS = gconf backends po doc examples
++SUBDIRS = gconf backends po examples
+ DIST_SUBDIRS=tests $(SUBDIRS)
+
++if ENABLE_GTK_DOC
++SUBDIRS += doc
++endif
++
+ EXTRA_DIST = \
+ TODO \
+ gtk-doc.make \
diff --git a/gnome-base/gconf/gconf-2.14.0.ebuild b/gnome-base/gconf/gconf-2.14.0.ebuild
deleted file mode 100644
index 96a48d51974c..000000000000
--- a/gnome-base/gconf/gconf-2.14.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.14.0.ebuild,v 1.16 2007/03/10 15:02:17 vapier Exp $
-
-inherit gnome2
-
-MY_PN=GConf
-MY_P=${MY_PN}-${PV}
-PVP=(${PV//[-\._]/ })
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Gnome Configuration System and Daemon"
-HOMEPAGE="http://www.gnome.org/"
-SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="doc"
-
-RDEPEND=">=dev-libs/glib-2.10
- >=x11-libs/gtk+-2.8.16
- >=gnome-base/orbit-2.4
- >=dev-libs/libxml2-2
- dev-libs/popt"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9
- doc? ( >=dev-util/gtk-doc-1 )"
-
-# FIXME : consider merging the tree (?)
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-pkg_setup() {
- G2CONF="${G2CONF} --enable-gtk"
- kill_gconf
-}
-
-src_install() {
- gnome2_src_install
-
- # hack hack
- dodir /etc/gconf/gconf.xml.mandatory
- dodir /etc/gconf/gconf.xml.defaults
- touch "${D}"/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
- touch "${D}"/etc/gconf/gconf.xml.defaults/.keep${SLOT}
-
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
- doenvd 50gconf || die
- dodir /root/.gconfd
-}
-
-kill_gconf() {
- # this function will kill all running gconfd that could be causing troubles
- if [ -x /usr/bin/gconftool ]
- then
- /usr/bin/gconftool --shutdown
- fi
- if [ -x /usr/bin/gconftool-1 ]
- then
- /usr/bin/gconftool-1 --shutdown
- fi
-
- # and for gconf 2
- if [ -x /usr/bin/gconftool-2 ]
- then
- /usr/bin/gconftool-2 --shutdown
- fi
- return 0
-}
-
-pkg_preinst() {
- kill_gconf
-}
-
-pkg_postinst() {
- kill_gconf
-
- #change the permissions to avoid some gconf bugs
- einfo "changing permissions for gconf dirs"
- find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
- einfo "changing permissions for gconf files"
- find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
-}
diff --git a/gnome-base/gconf/gconf-2.20.1-r1.ebuild b/gnome-base/gconf/gconf-2.20.1-r1.ebuild
index 5586659d0a13..8bc46b97f995 100644
--- a/gnome-base/gconf/gconf-2.20.1-r1.ebuild
+++ b/gnome-base/gconf/gconf-2.20.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.20.1-r1.ebuild,v 1.2 2008/01/02 07:06:17 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.20.1-r1.ebuild,v 1.3 2008/01/26 13:27:25 eva Exp $
inherit gnome2 autotools
@@ -41,9 +41,9 @@ src_unpack() {
# fix bug #193442
epatch "${FILESDIR}/${P}-automagic-ldap.patch"
+ use doc || epatch "${FILESDIR}/${P}-drop-gtk-doc.patch"
- cp aclocal.m4 old.m4
- AT_M4DIR="." eautoreconf
+ eautoreconf
}
src_install() {