summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/gconf-1.0.4-r2.ebuild44
-rw-r--r--gnome-base/gnome-applets/gnome-applets-1.4.0.4-r1.ebuild41
-rw-r--r--gnome-base/gnome-core/gnome-core-1.4.0.4-r1.ebuild48
-rw-r--r--gnome-base/gnome-vfs/gnome-vfs-1.0.2-r1.ebuild33
4 files changed, 166 insertions, 0 deletions
diff --git a/gnome-base/gconf/gconf-1.0.4-r2.ebuild b/gnome-base/gconf/gconf-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..086366c3fb10
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.0.4-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.4-r2.ebuild,v 1.1 2001/10/06 10:47:27 hallski Exp $
+
+P=GConf-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Gconf"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/GConf/${A}"
+
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=sys-libs/db-3.2.3h
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/gnome-libs-1.4.1.2-r1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/guile-1.4"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ mkdir intl
+ touch intl/libgettext.h
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}
diff --git a/gnome-base/gnome-applets/gnome-applets-1.4.0.4-r1.ebuild b/gnome-base/gnome-applets/gnome-applets-1.4.0.4-r1.ebuild
new file mode 100644
index 000000000000..1b29bc4cb885
--- /dev/null
+++ b/gnome-base/gnome-applets/gnome-applets-1.4.0.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-1.4.0.4-r1.ebuild,v 1.1 2001/10/06 10:47:27 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnome-applets"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=gnome-base/gnome-core-1.4.0.4-r1
+ >=gnome-base/libgtop-1.0.12-r1
+ >=gnome-base/libghttp-1.0.9-r1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=app-text/scrollkeeper-0.2
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
diff --git a/gnome-base/gnome-core/gnome-core-1.4.0.4-r1.ebuild b/gnome-base/gnome-core/gnome-core-1.4.0.4-r1.ebuild
new file mode 100644
index 000000000000..1224a6327be2
--- /dev/null
+++ b/gnome-base/gnome-core/gnome-core-1.4.0.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-core/gnome-core-1.4.0.4-r1.ebuild,v 1.1 2001/10/06 10:47:27 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnome-core"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=gnome-base/control-center-1.4.0.1-r1
+ >=gnome-base/libglade-0.17-r1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=sys-apps/tcp-wrappers-7.6
+ >=app-text/scrollkeeper-0.2
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+src_compile() {
+ local myconf
+ local myldflags
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ if [ "`use kde`" ]
+ then
+ myconf="${myconf} --with-kde-datadir=/usr/share"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS
+}
diff --git a/gnome-base/gnome-vfs/gnome-vfs-1.0.2-r1.ebuild b/gnome-base/gnome-vfs/gnome-vfs-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..5474c3c64d36
--- /dev/null
+++ b/gnome-base/gnome-vfs/gnome-vfs-1.0.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-1.0.2-r1.ebuild,v 1.1 2001/10/06 10:47:27 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnome-vfs"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=gnome-base/gconf-1.0.4-r2"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+src_compile() {
+ local myconf
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}