summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin/dolphin-4.11.5.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.11.5.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.11.5.ebuild b/kde-base/dolphin/dolphin-4.11.5.ebuild
new file mode 100644
index 000000000000..f3e0484304ea
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.11.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.11.5.ebuild,v 1.1 2014/01/10 04:21:38 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+HOMEPAGE="http://dolphin.kde.org http://www.kde.org/applications/system/dolphin"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ x11-libs/libXrender
+ semantic-desktop? (
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ dev-libs/soprano
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep nepomuk-widgets)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ $(add_kdebase_dep thumbnailers)
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+RESTRICT="test"
+# bug 393129
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop NepomukCore)
+ $(cmake-utils_use_with semantic-desktop NepomukWidgets)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version media-gfx/icoutils ; then
+ elog "For .exe file preview support, install media-gfx/icoutils."
+ fi
+}