summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/lokalize/lokalize-4.4.5.ebuild')
-rw-r--r--kde-base/lokalize/lokalize-4.4.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/lokalize/lokalize-4.4.5.ebuild b/kde-base/lokalize/lokalize-4.4.5.ebuild
new file mode 100644
index 000000000000..3d15cd101d1a
--- /dev/null
+++ b/kde-base/lokalize/lokalize-4.4.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/lokalize/lokalize-4.4.5.ebuild,v 1.1 2010/06/30 15:36:44 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdesdk"
+PYTHON_DEPEND="2"
+inherit python kde4-meta
+
+DESCRIPTION="KDE4 translation tool"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+# Althrought they are purely runtime, its too useless without them
+DEPEND="
+ >=app-text/hunspell-1.2.8
+ >=x11-libs/qt-sql-4.5.0:4[sqlite]
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdesdk-strigi-analyzer)
+ $(add_kdebase_dep krosspython)
+ $(add_kdebase_dep pykde4)
+"
+
+pkg_setup() {
+ kde4-meta_pkg_setup
+ python_set_active_version 2
+}
+
+src_install() {
+ kde4-meta_src_install
+ python_convert_shebangs -q -r $(python_get_version) "${ED}${PREFIX}/share/apps/${PN}"
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ echo
+ elog "To be able to autofetch KDE translations in new project wizard, install subversion client:"
+ elog " emerge -vau subversion"
+ echo
+}