summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/mplayerthumbs/mplayerthumbs-4.3.1.ebuild')
-rw-r--r--kde-base/mplayerthumbs/mplayerthumbs-4.3.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/mplayerthumbs/mplayerthumbs-4.3.1.ebuild b/kde-base/mplayerthumbs/mplayerthumbs-4.3.1.ebuild
new file mode 100644
index 000000000000..f17bfbc88c9f
--- /dev/null
+++ b/kde-base/mplayerthumbs/mplayerthumbs-4.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/mplayerthumbs/mplayerthumbs-4.3.1.ebuild,v 1.1 2009/09/01 16:21:27 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdemultimedia"
+inherit kde4-meta
+
+DESCRIPTION="A Thumbnail Generator for Video Files on KDE filemanagers."
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=41180"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug mplayer"
+
+RDEPEND="
+ !media-video/mplayerthumbs
+ || (
+ >=kde-base/dolphin-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/konqueror-${PV}:${SLOT}[kdeprefix=]
+ )
+ mplayer? (
+ || (
+ media-video/mplayer
+ media-video/mplayer-bin
+ )
+ )
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_PHONON_SUPPORT=ON"
+
+ kde4-meta_src_configure
+}