summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.4.5.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 41de8fac48a4..86e4e8f11a70 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.108 2010/06/28 03:53:49 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.109 2010/06/30 15:36:51 alexxy Exp $
+
+*smoke-4.4.5 (30 Jun 2010)
+
+ 30 Jun 2010; Alexey Shvetsov <alexxy@gentoo.org> +smoke-4.4.5.ebuild:
+ Version bump
28 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
smoke-4.4.4-r1.ebuild:
diff --git a/kde-base/smoke/smoke-4.4.5.ebuild b/kde-base/smoke/smoke-4.4.5.ebuild
new file mode 100644
index 000000000000..f3d20f444f90
--- /dev/null
+++ b/kde-base/smoke/smoke-4.4.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.4.5.ebuild,v 1.1 2010/06/30 15:36:51 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+MULTIMEDIA_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="akonadi attica debug okular +phonon qimageblitz qscintilla qwt semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ attica? ( dev-libs/libattica )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-sound/phonon-4.3.80[xcb] )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_enable attica ATTICA_SMOKE)
+ $(cmake-utils_use_enable multimedia QTMULTIMEDIA_SMOKE)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_enable phonon PHONON_SMOKE)
+ $(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SMOKE)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_enable qwt QWT_SMOKE)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_enable webkit QTWEBKIT_SMOKE)
+ )
+ kde4-meta_src_configure
+}