summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/ChangeLog8
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.10.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-frameworks/frameworkintegration/ChangeLog b/kde-frameworks/frameworkintegration/ChangeLog
index b87d5ebdda95..307169887963 100644
--- a/kde-frameworks/frameworkintegration/ChangeLog
+++ b/kde-frameworks/frameworkintegration/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-frameworks/frameworkintegration
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/ChangeLog,v 1.16 2015/04/11 17:09:50 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/ChangeLog,v 1.17 2015/05/09 10:36:06 mrueg Exp $
+
+*frameworkintegration-5.10.0 (09 May 2015)
+
+ 09 May 2015; Manuel Rüger <mrueg@gentoo.org>
+ +frameworkintegration-5.10.0.ebuild:
+ Version bump.
*frameworkintegration-5.9.0 (11 Apr 2015)
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.10.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.10.0.ebuild
new file mode 100644
index 000000000000..588d21dedf3f
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/frameworkintegration-5.10.0.ebuild,v 1.1 2015/05/09 10:36:06 mrueg Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_plasma_dep oxygen-fonts)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}