summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.7.ebuild')
-rw-r--r--mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.7.ebuild b/mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.7.ebuild
new file mode 100644
index 000000000000..049a11fb02bb
--- /dev/null
+++ b/mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.7.ebuild,v 1.1 2006/11/13 17:55:00 ticho Exp $
+
+MY_P="${P#sylpheed-claws-}"
+
+DESCRIPTION="This plugin allows you to read your favorite newsfeeds in Claws. RSS 1.0, 2.0 and Atom feeds are currently supported."
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+DEPEND=">=mail-client/sylpheed-claws-2.6.0
+ net-misc/curl
+ dev-libs/libxml2
+ nls? ( >=sys-devel/gettext-0.12.1 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ # kill useless files
+ rm -f ${D}/usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}