summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog8
-rw-r--r--mail-client/sylpheed/Manifest4
-rw-r--r--mail-client/sylpheed/files/digest-sylpheed-1.0.4-r11
-rw-r--r--mail-client/sylpheed/sylpheed-1.0.4-r1.ebuild73
4 files changed, 84 insertions, 2 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 33beabe991b7..4bf24df0b503 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/sylpheed
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.103 2005/04/23 12:54:23 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.104 2005/05/05 13:58:53 hattya Exp $
+
+*sylpheed-1.0.4-r1 (05 May 2005)
+
+ 05 May 2005; Akinori Hattori <hattya@gentoo.org>
+ +sylpheed-1.0.4-r1.ebuild:
+ fixes bug #90439
23 Apr 2005; Akinori Hattori <hattya@gentoo.org> -sylpheed-1.9.8.ebuild:
remove old ebuild.
diff --git a/mail-client/sylpheed/Manifest b/mail-client/sylpheed/Manifest
index 099d1aa3823c..5722c3db59c3 100644
--- a/mail-client/sylpheed/Manifest
+++ b/mail-client/sylpheed/Manifest
@@ -1,8 +1,10 @@
-MD5 cd2aaef97511f171d0a5a7fddca7f30d ChangeLog 22748
+MD5 122c935deee933ce116a91d0d75ac097 ChangeLog 22882
MD5 126ca8f672f0296d2f1e6830e6729a91 metadata.xml 231
+MD5 db393825e6a7c2e3ae043389a696811a sylpheed-1.0.4-r1.ebuild 1475
MD5 b24edf1dd3b5d0347d0798e571c9bb87 sylpheed-1.0.4.ebuild 1610
MD5 109e44ecb36a74c3f393e2ede8c62486 sylpheed-1.9.9.ebuild 1485
MD5 a362fe1639f77a7898dfeab021cf9ca2 files/digest-sylpheed-1.0.4 68
+MD5 a362fe1639f77a7898dfeab021cf9ca2 files/digest-sylpheed-1.0.4-r1 68
MD5 990bb753d04a13856fdb53beb6ad4255 files/digest-sylpheed-1.9.9 68
MD5 4cbec71671b7349c904f860a12fee5d9 files/sylpheed-namespace.diff 550
MD5 f4242298cfab21456442bfe52505d2b8 files/sylpheed-procmime.diff 1119
diff --git a/mail-client/sylpheed/files/digest-sylpheed-1.0.4-r1 b/mail-client/sylpheed/files/digest-sylpheed-1.0.4-r1
new file mode 100644
index 000000000000..4d36906637a1
--- /dev/null
+++ b/mail-client/sylpheed/files/digest-sylpheed-1.0.4-r1
@@ -0,0 +1 @@
+MD5 e47b275c281335d09201503af2115eaa sylpheed-1.0.4.tar.bz2 2377662
diff --git a/mail-client/sylpheed/sylpheed-1.0.4-r1.ebuild b/mail-client/sylpheed/sylpheed-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..9888f3bf0b4a
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-1.0.4-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-1.0.4-r1.ebuild,v 1.1 2005/05/05 13:58:53 hattya Exp $
+
+inherit eutils
+
+IUSE="crypt gnome imlib ipv6 ldap nls pda ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.good-day.net/"
+SRC_URI="http://sylpheed.good-day.net/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ !amd64? ( nls? ( >=sys-devel/gettext-0.12.1 ) )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ gnome? ( media-libs/gdk-pixbuf )
+ imlib? ( media-libs/imlib )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-namespace.diff
+ epatch ${FILESDIR}/${PN}-procmime.diff
+
+}
+
+src_compile() {
+
+ econf \
+ `use_enable nls` \
+ `use_enable ssl` \
+ `use_enable crypt gpgme` \
+ `use_enable pda jpilot` \
+ `use_enable ldap` \
+ `use_enable ipv6` \
+ `use_enable imlib` \
+ `use_enable gnome gdk-pixbuf` \
+ `use_enable xface compface` \
+ || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ einstall
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ insinto /usr/share/applications
+ doins sylpheed.desktop
+
+ dodoc AUTHORS COPYING ChangeLog* INSTALL* NEWS* README* TODO*
+
+}