summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pixie/files/pixie-1.4.7-libtool.patch')
-rw-r--r--media-gfx/pixie/files/pixie-1.4.7-libtool.patch428
1 files changed, 428 insertions, 0 deletions
diff --git a/media-gfx/pixie/files/pixie-1.4.7-libtool.patch b/media-gfx/pixie/files/pixie-1.4.7-libtool.patch
new file mode 100644
index 000000000000..665fd7f25c0d
--- /dev/null
+++ b/media-gfx/pixie/files/pixie-1.4.7-libtool.patch
@@ -0,0 +1,428 @@
+diff -Naurp Pixie.orig/Makefile.am Pixie/Makefile.am
+--- Pixie.orig/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -1,30 +1,4 @@
+ SUBDIRS = src
+-
+-if SELFCONTAINED
+- pixdatadir = $(prefix)
+- docdir = $(prefix)
+- htmldocdir = $(docdir)/html
+- shaderdir = $(pixdatadir)/shaders
+-else
+- pixdatadir = $(libdir)/$(PACKAGE)
+- docdir = $(datadir)/doc/$(PACKAGE)
+- htmldocdir = $(docdir)/html
+- shaderdir = $(pixdatadir)/shaders
+-endif
+-
+-doc_DATA = README AUTHORS LICENSE COPYING
+-
+ man_MANS = man/rndr.1 man/sdrc.1 man/sdrinfo.1 man/texmake.1
+-
+-EXTRA_DIST = DEVNOTES LICENSE
+-
+-dist-hook:
+- cp -rf $(srcdir)/doc $(distdir)
+- cp -rf $(srcdir)/shaders $(distdir)
+-
+-install-data-hook:
+- mkdir -p $(htmldocdir)
+- cp -rf $(srcdir)/doc/* $(htmldocdir)
+- mkdir -p $(shaderdir)
+- cp -rf $(srcdir)/shaders/* $(shaderdir)
+-
++doc_DATA = AUTHORS ChangeLog COPYING DEVNOTES LICENSE NEWS README doc/*
++shader_DATA = shaders/*
+diff -Naurp Pixie.orig/configure.in Pixie/configure.in
+--- Pixie.orig/configure.in 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/configure.in 2005-10-02 23:33:31.000000000 +0000
+@@ -14,6 +14,7 @@ dnl
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_CXX
++AM_DISABLE_STATIC
+ AM_PROG_LIBTOOL
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+@@ -94,17 +95,80 @@ AC_SUBST(TIFF_LIBS)
+ AC_SUBST(BUILD_SHOW)
+
+ dnl ---------------------------------------------------
++dnl Set custom directories for shaders, models, procedurals, and displays
++dnl
++
++AC_ARG_WITH(docdir,
++ AS_HELP_STRING([--with-docdir=DIR],[directory where we install documentation (Default: DATADIR/doc/Pixie)]),
++ docdir="${withval}",
++ docdir="${datadir}/doc/Pixie")
++
++AC_ARG_WITH(shaderdir,
++ AS_HELP_STRING([--with-shaderdir=DIR],[directory where we store shaders (Default: DATADIR/Pixie/shaders)]),
++ shaderdir="${withval}",
++ shaderdir="${datadir}/Pixie/shaders")
++
++AC_ARG_WITH(modeldir,
++ AS_HELP_STRING([--with-modeldir=DIR],[directory where we store models (Default: DATADIR/Pixie/models)]),
++ modeldir="${withval}",
++ modeldir="${datadir}/Pixie/models")
++
++AC_ARG_WITH(texturedir,
++ AS_HELP_STRING([--with-modeldir=DIR],[directory where we store models (Default: DATADIR/Pixie/textures)]),
++ texturedir="${withval}",
++ texturedir="${datadir}/Pixie/textures")
++
++AC_ARG_WITH(proceduraldir,
++ AS_HELP_STRING([--with-shaderdir=DIR],[directory to store shaders (Default: LIBDIR/Pixie/procedurals)]),
++ proceduraldir="${withval}",
++ proceduraldir="${libdir}/Pixie/procedurals")
++
++AC_ARG_WITH(displaysdir,
++ AS_HELP_STRING([--with-displaysdir=DIR],[directory to store displays (Default: LIBDIR/Pixie/displays)]),
++ displaysdir="${withval}",
++ displaysdir="${libdir}/Pixie/displays")
++
++dnl ---------------------------------------------------
+ dnl Are we building for self contained distribution
+ dnl
+
+ AC_ARG_ENABLE(selfcontained,
+-AS_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup]),
++AS_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup (overrides custom directory settings)]),
+ [case "${enableval}" in
+-yes) selfcontained=true ;;
+-no) selfcontained=false ;;
+-*) AC_MSG_ERROR(bad value ${enableval} for --enable-selfcontained) ;;
+-esac],[selfcontained=false])
+-AM_CONDITIONAL(SELFCONTAINED, test x$selfcontained = xtrue)
++ yes) docdir="${prefix}/doc"
++ shaderdir="${prefix}/shaders"
++ modeldir="${prefix}/models"
++ texturedir="${prefix}/textures"
++ displaysdir="${prefix}/displays"
++ proceduraldir="${prefix}/procedurals"
++ ;;
++ no) ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-selfcontained) ;;
++esac])
++
++dnl ---------------------------------------------------
++dnl Now tell the c preprocessor and the Makefiles where stuff goes
++dnl
++
++AC_DEFUN([AC_DEFINE_DIR], [
++ prefix_NONE=
++ exec_prefix_NONE=
++ test "x$prefix" = xNONE && prefix_NONE=yes && prefix=$ac_default_prefix
++ test "x$exec_prefix" = xNONE && exec_prefix_NONE=yes && exec_prefix=$prefix
++ eval ac_define_dir="\"[$]$2\""
++ AC_SUBST($1, "$ac_define_dir")
++ AC_SUBST($2, "$ac_define_dir")
++ AC_DEFINE_UNQUOTED($1, "$ac_define_dir", [$3])
++ test "$prefix_NONE" && prefix=NONE
++ test "$exec_prefix_NONE" && exec_prefix=NONE
++])
++
++AC_DEFINE_DIR(PIXIE_DOCS,docdir,[Directory where we store documentation])
++AC_DEFINE_DIR(PIXIE_SHADERS,shaderdir,[Directory where we store shaders])
++AC_DEFINE_DIR(PIXIE_MODELS,modeldir,[Directory where we store models])
++AC_DEFINE_DIR(PIXIE_TEXTURES,texturedir,[Directory where we store textures])
++AC_DEFINE_DIR(PIXIE_DISPLAYS,displaysdir,[Directory where we store displays])
++AC_DEFINE_DIR(PIXIE_PROCEDURALS,proceduraldir,[Directory where we store procedurals])
+
+ dnl ---------------------------------------------------
+ dnl Write the output
+@@ -118,10 +182,3 @@ echo ">make -install"
+ echo "to built Pixie"
+ echo
+
+-
+-
+-
+-
+-
+-
+-
+diff -Naurp Pixie.orig/src/common/Makefile.am Pixie/src/common/Makefile.am
+--- Pixie.orig/src/common/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/common/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -1,6 +1,9 @@
+-noinst_LIBRARIES = libcommon.a
+-
+-libcommon_a_SOURCES = algebra.cpp os.cpp memoryman.cpp
+-libcommon_a_CFLAGS = -fPIC -DPIC
+-libcommon_a_CXXFLAGS = -fPIC -DPIC
+-
++lib_LTLIBRARIES = libpixiecommon.la
++
++LIBPIXIECOMMON_CURRENT_VERSION=0
++LIBPIXIECOMMON_REVISION_VERSION=0
++LIBPIXIECOMMON_AGE_VERSION=0
++
++libpixiecommon_la_LDFLAGS = -export-dynamic -version-info $(LIBPIXIECOMMON_CURRENT_VERSION):$(LIBPIXIECOMMON_REVISION_VERSION):$(LIBPIXIECOMMON_AGE_VERSION)
++
++libpixiecommon_la_SOURCES = algebra.cpp os.cpp memoryman.cpp
+diff -Naurp Pixie.orig/src/common/os.h Pixie/src/common/os.h
+--- Pixie.orig/src/common/os.h 2005-09-18 18:52:39.000000000 +0000
++++ Pixie/src/common/os.h 2005-10-02 23:32:15.000000000 +0000
+@@ -73,8 +73,10 @@ typedef void *(*TFun)(void *);
+ #endif
+
+ #include "global.h"
+-#include "../../config.h"
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
+
+ // Maximum length of a path
+ const int OS_MAX_PATH_LENGTH = 512;
+diff -Naurp Pixie.orig/src/file/Makefile.am Pixie/src/file/Makefile.am
+--- Pixie.orig/src/file/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/file/Makefile.am 2005-10-02 23:33:45.000000000 +0000
+@@ -1,15 +1,7 @@
+-
+-if SELFCONTAINED
+- displaysdir = $(prefix)/displays
+-else
+- displaysdir = $(libdir)/$(PACKAGE)/displays
+-endif
+-
+ displays_LTLIBRARIES = file.la
+
+-LIBS = @TIFF_LIBS@
+ file_la_SOURCES = file.cpp
+-file_la_LIBADD = ../common/libcommon.a
++file_la_LIBADD = ../common/libpixiecommon.la @TIFF_LIBS@
+ file_la_LDFLAGS = -module -avoid-version
+
+ INCLUDES = -I..
+diff -Naurp Pixie.orig/src/framebuffer/Makefile.am Pixie/src/framebuffer/Makefile.am
+--- Pixie.orig/src/framebuffer/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/framebuffer/Makefile.am 2005-10-02 23:33:53.000000000 +0000
+@@ -1,16 +1,9 @@
++displays_LTLIBRARIES = framebuffer.la
+
+-if SELFCONTAINED
+- displaysdir = $(prefix)/displays
+-else
+- displaysdir = $(libdir)/$(PACKAGE)/displays
+-endif
+-
+-displays_LTLIBRARIES = framebuffer.la
+-
+-CFLAGS = @CFLAGS@ @X_CFLAGS@
+ framebuffer_la_SOURCES = framebuffer.cpp fbx.cpp
+-framebuffer_la_LIBADD = ../common/libcommon.a @X_LIBS@
++framebuffer_la_LIBADD = ../common/libpixiecommon.la @X_LIBS@
+ framebuffer_la_LDFLAGS = -module -avoid-version @X_LDFLAGS@
++framebuffer_la_CXXFLAGS = @X_CFLAGS@
+
+ INCLUDES = -I..
+
+diff -Naurp Pixie.orig/src/precomp/Makefile.am Pixie/src/precomp/Makefile.am
+--- Pixie.orig/src/precomp/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/precomp/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -2,7 +2,7 @@ bin_PROGRAMS = precomp
+
+ precomp_SOURCES = precomp.cpp
+
+-precomp_LDADD = ../common/libcommon.a
++precomp_LDADD = ../common/libpixiecommon.la
+
+ INCLUDES = -I..
+
+diff -Naurp Pixie.orig/src/rgbe/Makefile.am Pixie/src/rgbe/Makefile.am
+--- Pixie.orig/src/rgbe/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/rgbe/Makefile.am 2005-10-02 23:34:01.000000000 +0000
+@@ -1,14 +1,7 @@
+-
+-if SELFCONTAINED
+- displaysdir = $(prefix)/displays
+-else
+- displaysdir = $(libdir)/$(PACKAGE)/displays
+-endif
+-
+ displays_LTLIBRARIES = rgbe.la
+
+ rgbe_la_SOURCES = file.cpp rgbe.cpp
+-rgbe_la_LIBADD = ../common/libcommon.a
++rgbe_la_LIBADD = ../common/libpixiecommon.la
+ rgbe_la_LDFLAGS = -module -avoid-version
+
+ INCLUDES = -I..
+diff -Naurp Pixie.orig/src/ri/Makefile.am Pixie/src/ri/Makefile.am
+--- Pixie.orig/src/ri/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/ri/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -1,6 +1,10 @@
+ lib_LTLIBRARIES = libri.la
+
+-LIBS = @TIFF_LIBS@
++LIBRI_CURRENT_VERSION=0
++LIBRI_REVISION_VERSION=0
++LIBRI_AGE_VERSION=0
++
++libri_la_LDFLAGS = -export-dynamic -version-info $(LIBRI_CURRENT_VERSION):$(LIBRI_REVISION_VERSION):$(LIBRI_AGE_VERSION)
+ libri_la_SOURCES = attributes.cpp \
+ bundles.cpp \
+ cache.cpp \
+@@ -61,8 +65,7 @@ libri_la_SOURCES = attributes.cpp \
+ xform.cpp \
+ zbuffer.cpp
+
+-libri_la_LIBADD = ../common/libcommon.a
+-libri_la_LDFLAGS = -version-info 0:0:0
++libri_la_LIBADD = ../common/libpixiecommon.la @TIFF_LIBS@
+
+ INCLUDES = -I..
+
+diff -Naurp Pixie.orig/src/ri/options.cpp Pixie/src/ri/options.cpp
+--- Pixie.orig/src/ri/options.cpp 2005-09-18 18:52:38.000000000 +0000
++++ Pixie/src/ri/options.cpp 2005-10-02 23:32:15.000000000 +0000
+@@ -37,6 +37,10 @@
+ #include "renderer.h"
+ #include "stats.h"
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ ///////////////////////////////////////////////////////////////////////
+ // Class : COptions
+ // Method : optionsDeleteSearchPath
+@@ -256,18 +260,38 @@ COptions::COptions() {
+
+ hider = strdup("stochastic");
+
+- archivePath = optionsGetSearchPath(".:%PIXIEHOME%/models:%RIBS%",NULL);
++#ifndef PIXIE_MODELS
++#define PIXIE_MODELS "%PIXIEHOME%/models"
++#endif
++
++#ifndef PIXIE_PROCEDURALS
++#define PIXIE_PROCEDURALS "%PIXIE_PROCEDURALS%"
++#endif
++
++#ifndef PIXIE_TEXTURES
++#define PIXIE_TEXTURES "%PIXIEHOME%/textures"
++#endif
++
++#ifndef PIXIE_SHADERS
++#define PIXIE_SHADERS "%PIXIEHOME%/shaders"
++#endif
++
++#ifndef PIXIE_DISPLAYS
++#define PIXIE_DISPLAYS "%PIXIE_DISPLAY%"
++#endif
++
++ archivePath = optionsGetSearchPath(".:%PIXIEHOME%/models:%RIBS%:" PIXIE_MODELS,NULL);
+ #ifdef _DEBUG
+- proceduralPath = optionsGetSearchPath(".:%PIXIEHOME%/procedurals:%PIXIEHOME%/bind:%PROCEDURALS%",NULL);
++ proceduralPath = optionsGetSearchPath(".:%PIXIEHOME%/procedurals:%PIXIEHOME%/bind:%PIXIE_PROCEDURALS%:%PROCEDURALS%",NULL);
+ #else
+- proceduralPath = optionsGetSearchPath(".:%PIXIEHOME%/procedurals:%PIXIEHOME%/lib:%PROCEDURALS%",NULL);
++ proceduralPath = optionsGetSearchPath(".:%PIXIEHOME%/procedurals:%PIXIEHOME%/lib:%PIXIE_PROCEDURALS%:%PROCEDURALS%:" PIXIE_PROCEDURALS,NULL);
+ #endif
+- texturePath = optionsGetSearchPath(".:%PIXIEHOME%/textures:%TEXTURES%",NULL);
+- shaderPath = optionsGetSearchPath(".:%PIXIEHOME%/shaders:%SHADERS%",NULL);
++ texturePath = optionsGetSearchPath(".:%PIXIEHOME%/textures:%TEXTURES%:" PIXIE_TEXTURES,NULL);
++ shaderPath = optionsGetSearchPath(".:%PIXIEHOME%/shaders:%SHADERS%:" PIXIE_SHADERS,NULL);
+ #ifdef _DEBUG
+- displayPath = optionsGetSearchPath(".:%PIXIEHOME%/bind:%DISPLAYS%",NULL);
++ displayPath = optionsGetSearchPath(".:%PIXIEHOME%/bind:%PIXIE_DISPLAY%:%DISPLAYS%",NULL);
+ #else
+- displayPath = optionsGetSearchPath(".:%PIXIEHOME%/displays:%DISPLAYS%",NULL);
++ displayPath = optionsGetSearchPath(".:%PIXIEHOME%/displays:%PIXIE_DISPLAY%:%DISPLAYS%:" PIXIE_DISPLAYS,NULL);
+ #endif
+ temporaryPath = strdup("temp");
+
+diff -Naurp Pixie.orig/src/rndr/Makefile.am Pixie/src/rndr/Makefile.am
+--- Pixie.orig/src/rndr/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/rndr/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -1,7 +1,7 @@
+ bin_PROGRAMS = rndr
+
+ rndr_SOURCES = rndr.cpp
+-rndr_LDADD = ../ri/libri.la ../common/libcommon.a
++rndr_LDADD = ../ri/libri.la ../common/libpixiecommon.la
+
+ INCLUDES = -I..
+
+diff -Naurp Pixie.orig/src/sdr/Makefile.am Pixie/src/sdr/Makefile.am
+--- Pixie.orig/src/sdr/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/sdr/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -1,9 +1,14 @@
+ lib_LTLIBRARIES = libsdr.la
+
++LIBSDR_CURRENT_VERSION=0
++LIBSDR_REVISION_VERSION=0
++LIBSDR_AGE_VERSION=0
++
++libsdr_la_LDFLAGS = -export-dynamic -version-info $(LIBSDR_CURRENT_VERSION):$(LIBSDR_REVISION_VERSION):$(LIBSDR_AGE_VERSION)
++
+ libsdr_la_SOURCES = sdr.cpp
+
+-libsdr_la_LIBADD = ../common/libcommon.a
+-libsdr_la_LDFLAGS = -version-info 0:0:0
++libsdr_la_LIBADD = ../common/libpixiecommon.la
+
+ INCLUDES = -I..
+
+diff -Naurp Pixie.orig/src/sdrc/Makefile.am Pixie/src/sdrc/Makefile.am
+--- Pixie.orig/src/sdrc/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/sdrc/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -1,7 +1,7 @@
+ bin_PROGRAMS = sdrc
+
+ sdrc_SOURCES = sdrc.cpp dso.cpp expression.cpp opcodes.cpp sdr.cpp sl.cpp pp1.c pp2.c pp3.c pp4.c pp5.c pp6.c pp7.c pp8.c
+-sdrc_LDADD = ../common/libcommon.a
++sdrc_LDADD = ../common/libpixiecommon.la
+
+ INCLUDES = -I..
+
+diff -Naurp Pixie.orig/src/sdrinfo/Makefile.am Pixie/src/sdrinfo/Makefile.am
+--- Pixie.orig/src/sdrinfo/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/sdrinfo/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -1,7 +1,7 @@
+ bin_PROGRAMS = sdrinfo
+
+ sdrinfo_SOURCES = sdrinfo.cpp
+-sdrinfo_LDADD = ../sdr/libsdr.la ../common/libcommon.a
++sdrinfo_LDADD = ../sdr/libsdr.la ../common/libpixiecommon.la
+
+ INCLUDES = -I..
+
+diff -Naurp Pixie.orig/src/show/Makefile.am Pixie/src/show/Makefile.am
+--- Pixie.orig/src/show/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/show/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -4,8 +4,6 @@ endif
+
+ EXTRA_DIST = *.h show.dsp
+
+-CFLAGS = @CFLAGS@ @X_CFLAGS@
+-
+ show_SOURCES = cacheView.cpp \
+ radView.cpp \
+ interface.cpp \
+@@ -13,7 +11,7 @@ show_SOURCES = cacheView.cpp \
+ photonView.cpp \
+ show.cpp
+
+-show_LDADD = @X_LIBS@ @LIBFLTK@ @LIBFLTKGL@ @X_LDFLAGS@ ../common/libcommon.a
++show_LDADD = @X_LIBS@ @LIBFLTK@ @LIBFLTKGL@ @X_LDFLAGS@ ../common/libpixiecommon.la
++show_CXXFLAGS = @X_CFLAGS@
+
+ INCLUDES = -I..
+-
+diff -Naurp Pixie.orig/src/texmake/Makefile.am Pixie/src/texmake/Makefile.am
+--- Pixie.orig/src/texmake/Makefile.am 2005-09-18 18:52:42.000000000 +0000
++++ Pixie/src/texmake/Makefile.am 2005-10-02 23:32:15.000000000 +0000
+@@ -1,7 +1,7 @@
+ bin_PROGRAMS = texmake
+
+ texmake_SOURCES = texmake.cpp
+-texmake_LDADD = ../ri/libri.la ../common/libcommon.a
++texmake_LDADD = ../ri/libri.la ../common/libpixiecommon.la
+
+ INCLUDES = -I..
+