summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libnjb/libnjb-1.0.ebuild')
-rw-r--r--media-libs/libnjb/libnjb-1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/libnjb/libnjb-1.0.ebuild b/media-libs/libnjb/libnjb-1.0.ebuild
new file mode 100644
index 000000000000..470b43759922
--- /dev/null
+++ b/media-libs/libnjb/libnjb-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libnjb/libnjb-1.0.ebuild,v 1.1 2003/12/08 21:14:52 rphillips Exp $
+
+DESCRIPTION="libnjb is a C library and API for communicating with the Creative Nomad JukeBox digital audio player under BSD and Linux."
+HOMEPAGE="http://libnjb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=">=dev-libs/libusb/libusb-0.1.7"
+S="${WORKDIR}/libnjb"
+
+src_compile() {
+
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/libnjb-errno.patch
+
+ sed -i "s:all\: lib samples filemodes:all\: lib filemodes:g" Makefile.in
+ econf
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ prepalldocs
+ dodoc FAQ LICENSE INSTALL CHANGES README
+}