summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/mesa-6.5.2-r1.ebuild')
-rw-r--r--media-libs/mesa/mesa-6.5.2-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-6.5.2-r1.ebuild b/media-libs/mesa/mesa-6.5.2-r1.ebuild
index fcc8360e0a28..c676d20e764d 100644
--- a/media-libs/mesa/mesa-6.5.2-r1.ebuild
+++ b/media-libs/mesa/mesa-6.5.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5.2-r1.ebuild,v 1.13 2007/08/07 12:48:39 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.5.2-r1.ebuild,v 1.14 2007/08/12 05:12:36 dberkholz Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -80,6 +80,11 @@ pkg_setup() {
append-flags -fno-strict-aliasing
+ # gcc 4.2 has buggy ivopts
+ if [[ $(gcc-version) = "4.2" ]]; then
+ append-flags -fno-ivopts
+ fi
+
if use x86-fbsd; then
CONFIG="freebsd-dri-x86"
elif use amd64-fbsd; then